Bug #47869

Failed localization of FILES content object related to pages

Added by Eugene Skomorokhov over 8 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Category:
Frontend
Target version:
-
Start date:
2013-05-03
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Localization failed when references.table=pages used. The code in typo3/sysext/frontend/Classes/ContentObject/FlowPlayerContentObject.php line 73

if ($table === 'pages' && isset($this->cObj->data['_LOCALIZED_UID']) && intval($this->cObj->data['sys_language_uid']) > 0) {
    $table = 'pages_language_overlay';
}

doesn't working because of $this->cObj->data is NULL.


Related issues

Related to TYPO3 Core - Bug #48113: typoscript FILES object always uses default language when accessing page resource images of translated images Closed2013-05-11

Actions
Related to TYPO3 Core - Bug #58352: Invalid localization overlay of cObject FILESClosedOliver Hader2014-04-30

Actions
Related to TYPO3 Core - Bug #57272: Extbase doesn't handle FAL translations correctlyClosed2014-03-25

Actions
Related to TYPO3 Core - Bug #60998: PageRepository::shouldFieldBeOverlaid raises PHP warningClosed2014-08-15

Actions

Also available in: Atom PDF