Bug #49391

options.folderTree.altElementBrowserMountPoints (readonly filemounts) not working with FAL

Added by Fabian Thommen over 7 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2013-06-24
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

hi all

options.folderTree.altElementBrowserMountPoints is not working on my typo3 6.1.1 Version

in

sysext/recordlist/Classes/Controller/ElementBrowserController.php

on line 127 there is a comment:

case 'folder':
// Setting additional read-only browsing file mounts
// @todo: add this feature for FAL and TYPO3 6.0

so it looks like this has not been done.

thanks for fixing this

fabian


Related issues

Related to TYPO3 Core - Bug #47648: PHP Warning: rtrim() expects parameter 1 to be string in ElementBrowser.php line 1867Closed2013-04-27

Actions
Related to TYPO3 Core - Bug #63364: ReadOnly filemounts check does not respect evaluatePermissions settingClosed2014-11-27

Actions
Related to TYPO3 Core - Bug #58691: ResourceStorage->getProcessingFolder() won't create processing folder inside folder that does not have "Is Writable"Closed2014-05-09

Actions
Has duplicate TYPO3 Core - Feature #59569: Add permissions to BE-filemounts / Allow read-only filemountsClosed2014-06-13

Actions
Precedes TYPO3 Core - Feature #59830: Add a read_only column to the filemount tableClosed2014-06-23

Actions
#1

Updated by Fabian Thommen over 7 years ago

  • Target version changed from next-patchlevel to 6.2.0
#2

Updated by Ernesto Baschny over 7 years ago

  • Subject changed from options.folderTree.altElementBrowserMountPoints not working with FAL to options.folderTree.altElementBrowserMountPoints (readonly filemounts) not working with FAL
  • Status changed from New to Accepted

Yes, support for readonly file mounts would be a good asset again with FAL that is still missing. Thanks for bringing up the topic.

#3

Updated by Gerrit Code Review about 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25720

#4

Updated by Gerrit Code Review about 7 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25720

#5

Updated by Gerrit Code Review about 7 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25720

#6

Updated by Lorenz Ulrich about 7 years ago

I tested this feature and it works.

But to be honest: Isn't this a fix for a regression introduced with 6.0 instead of a feature?

In bigger websites with many editors, not every editor will have write access to all filemounts. But sometimes, editors still need to link to documents they can't manage.

In my opinion, this is an "enterprise feature" and it belongs to an LTS. I would suggest that this will be re-integrated into 6.2 instead of being postponed to 6.3.

#7

Updated by Gerrit Code Review about 7 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25720

#8

Updated by Ernesto Baschny about 7 years ago

  • Is Regression set to No

Yes, this can / should be reintegrated as a missing feature for the users coming from pre-6.0 installations!

Please talk to Steffen R about how this can be acomplished.

I would also suggest to keep support for the already existing and known "options.folderTree.altElementBrowserMountPoints" property.

#9

Updated by Gerrit Code Review about 7 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25720

#10

Updated by Gerrit Code Review about 7 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25720

#11

Updated by Lorenz Ulrich about 7 years ago

I found out that the current approach is no proper replacement for the feature it was before.

When I apply the patch and then add a "read-only" mountpoint pointing to /fileadmin, every other filemount poining to a subfolder of /fileadmin, e.g. /fileadmin/foo and /fileadmin/bar, is also read-only.

With the old feature I had the possibility to create a read-only filemount at top level and still have writable filemounts for sub levels.

#12

Updated by Fabien Udriot almost 7 years ago

Personally, I have nothing again the "read-only" flag being applied in cascade to the sub-folders. This would be the behaviour, I would expect as End User. However, options.folderTree.altElementBrowserMountPoints is suppose to display some special Mount Points only in the context of the Element Browser. Those Mount Points are not meant to be displayed in the File Module. That is not supported in the current implementation. We could "better" initialize the file storage in the Element Browser IMO.

#13

Updated by Fabien Udriot almost 7 years ago

BTW, documentation must be updated.
http://docs.typo3.org/typo3cms/TSconfigReference/UserTsconfig/Options/Index.html

Either the option is obsolete with this patch and must be removed or it gets fixed.

#14

Updated by Gerrit Code Review almost 7 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25720

#15

Updated by Alexander Stehlik almost 7 years ago

Hi guys,

I already tried to reimplement options.folderTree.altElementBrowserMountPoints but without success :( You can have a look at the first patch sets in Gerrit where this approach is implemented.

I think the current solution fits much better in the current infrastructure but I see the problem with the subfolders and will look into it.

Cheers,
Alex

#16

Updated by Lorenz Ulrich almost 7 years ago

Hi Alexander

I like to approach since it makes more sense than a TypoScript property. But I don't see the use case for the current solution. It would only be usable for read-only contents provided by the admin for editors, which is quite an edge case IMO.

I'll think about it.

Lorenz

#17

Updated by Gerrit Code Review almost 7 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25720

#18

Updated by Alexander Stehlik almost 7 years ago

Can you please test with the new version? Please note the dependency on the patch for #55416.

When I apply the patch and then add a "read-only" mountpoint pointing to /fileadmin, every other filemount poining to a subfolder of /fileadmin, e.g. /fileadmin/foo and /fileadmin/bar, is also read-only.

This should now be the other way around.

When you add a read-only mountpoint to /fileadmin/ the subdirectories within fileadmin for which writable filemounts exist will now also be writable within the /fileadmin/ filemount.

I hope this makes more sense now :)

#19

Updated by Gerrit Code Review almost 7 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25720

#20

Updated by Gerrit Code Review almost 7 years ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25720

#21

Updated by Gerrit Code Review over 6 years ago

Patch set 11 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25720

#22

Updated by Gerrit Code Review over 6 years ago

Patch set 12 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25720

#23

Updated by Gerrit Code Review over 6 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30685

#24

Updated by Lorenz Ulrich over 6 years ago

Steffen Ritter and I are currently working on a new implementation that doesn't add a database field. This way it can still go into 6.2. The patch is WIP, but here is what it will do:

It will re-integrate the TSconfig options.folderTree.altElementBrowserMountPoints in a backwards compatible way. In TYPO3 4.x, it worked like that:

options.folderTree.altElementBrowserMountPoints = documents,images

added a read-only filemount for folders fileadmin/documents and fileadmin/images to the Element Browser.

With FAL, an installation can have multiple storages and therefore the storage needs to be configured alongside the folder. To stay backwords compatible we assume that the old syntax refers to a folder in the default storage. So if the default storage is "fileadmin" on Local filesystem, the behaviour will be exactly the same, with the exception that it also displays the filemounts read-only in the File List Module.

The new syntax is:

options.folderTree.altElementBrowserMountPoints = 3:/test,documents,images,2:/

This will add:

  • Storage 3/test
  • [default storage]/documents
  • [default storage]/images
  • Storage 2:/

If you have overlapping storages, these are merged so that you don't have duplicates in the file browser.

#25

Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30685

#26

Updated by Gerrit Code Review over 6 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30685

#27

Updated by Gerrit Code Review over 6 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30685

#28

Updated by Gerrit Code Review over 6 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30685

#29

Updated by Gerrit Code Review over 6 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30685

#30

Updated by Gerrit Code Review over 6 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30685

#31

Updated by Gerrit Code Review over 6 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30685

#32

Updated by Gerrit Code Review over 6 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30685

#33

Updated by Gerrit Code Review over 6 years ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30685

#34

Updated by Gerrit Code Review over 6 years ago

Patch set 11 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30685

#35

Updated by Gerrit Code Review over 6 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/31075

#36

Updated by Gerrit Code Review over 6 years ago

Patch set 12 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30685

#37

Updated by Gerrit Code Review over 6 years ago

Patch set 13 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30685

#38

Updated by Gerrit Code Review over 6 years ago

Patch set 14 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30685

#39

Updated by Gerrit Code Review over 6 years ago

Patch set 15 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30685

#40

Updated by Gerrit Code Review over 6 years ago

Patch set 16 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30685

#41

Updated by Gerrit Code Review over 6 years ago

Patch set 17 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30685

#42

Updated by Gerrit Code Review over 6 years ago

Patch set 18 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30685

#43

Updated by Gerrit Code Review over 6 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/31496

#44

Updated by Gerrit Code Review over 6 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/31500

#45

Updated by Gerrit Code Review over 6 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/31501

#46

Updated by Helmut Hummel over 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#47

Updated by Riccardo De Contardi about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF