Project

General

Profile

Actions

Bug #52474

closed

Redirect generates wrong URLs if config.absRefPrefix is set to /

Added by Patrick Schriner over 10 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extbase
Target version:
Start date:
2013-10-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:
Remote Sprint

Description

This is still an issue for at least 4.5 (no kidding).

It could be resolved if Tx_Extbase_MVC_Controller_AbstractController->redirect calls ->setCreateAbsoluteUri(TRUE) when building the link (which should be fine?).

Alternatively addBaseUriIfNecessary / getBaseURI could be fixed to not add whatever is after the domain name, but I'd guess that has more consequences.

Steps to reproduce:

  1. set config.absRefPrefix to /
  2. Build redirect link

Files

Actions #1

Updated by Marc Bastian Heinrichs over 10 years ago

  • Status changed from New to Needs Feedback

What is the wrong URL in this case?

Actions #2

Updated by Patrick Schriner over 10 years ago

:D stupid me!

It's getting the first "/" twice: http://www.domain.com//index.php?id=34234

(As someone noted in the other related ticket: probably everything is duplicated)

Updated by Markus Günther over 10 years ago

I have created a little test extension to find out if this is still a problem. And it is reproduceable.

Actions #4

Updated by Alexander Opitz over 9 years ago

  • Project changed from 534 to TYPO3 Core
  • Category changed from Extbase: MVC to Extbase
  • Status changed from Needs Feedback to New
  • Target version deleted (4.5.30)
  • TYPO3 Version set to 4.5
  • Is Regression set to No
Actions #5

Updated by Benni Mack almost 9 years ago

  • Target version set to 7.4 (Backend)
  • Sprint Focus set to On Location Sprint
Actions #6

Updated by Marcel Wieser almost 9 years ago

As far as I can see, this issue doesn't exist in the current master anymore.

Actions #7

Updated by Tobias Liebig almost 9 years ago

I also can't reproduce this in 7.4-dev.
Also \TYPO3\CMS\Extbase\Mvc\Controller\AbstractController::redirect already correctly sets ->setCreateAbsoluteUri(TRUE) as suggested.

Actions #8

Updated by Susanne Moog almost 9 years ago

  • Target version changed from 7.4 (Backend) to 7.5
Actions #9

Updated by Anja Leichsenring almost 9 years ago

  • Sprint Focus changed from On Location Sprint to Remote Sprint
Actions #10

Updated by Nicole Cordes over 8 years ago

Attached a current version of the test extension which proofs that is issue is solved.

Actions #11

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF