Feature #53421

Media Element

Added by Kay Strobach over 7 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2013-11-07
Due date:
% Done:

0%

Estimated time:
PHP Version:
5.4
Tags:
Complexity:
easy
Sprint Focus:

Description

Youtube video urls in the media element are rendered as object, but should be rendered as iframe to be IOS / Android enabled.


Related issues

Related to TYPO3 Core - Feature #25718: Support <iframe> inclusion for Media Content ElementClosed2011-04-01

Actions
Related to TYPO3 Core - Feature #61799: Improve the handling of media filesClosedFrans Saris2014-09-22

Actions
Related to TYPO3 Core - Bug #44633: Media-element: Vimeo-video can not play via HTML5Closed2013-01-18

Actions
#1

Updated by Georg Ringer over 7 years ago

  • Tracker changed from Bug to Feature

certainly a feature and not a bug to have an alternative rendering method

#2

Updated by Kay Strobach over 7 years ago

mhmm, for me it's a bug, as it just works on desktops this way, neither android nor IOS show the video with the object rendering :(

#3

Updated by Georg Ringer over 7 years ago

mobile gave up flash support, so the "bug" is there ;)

so you wanna make a patch for this? and don't forget that this is not only about youtube but also other video hosters who got iframe support

#4

Updated by Gerrit Code Review about 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30923

#5

Updated by Markus Hölzle about 7 years ago

I have just checked the other video providers: Dailymotion, Vimeo, ClipFish, Liveleak, Metacafe, MyVideo now use iframes.
Sevenload and Google Video no longer exist.
Only Veoh still uses flash.

All providers should be updated because it's necessary to embed videos on smartphones and for responsive layouts.

#6

Updated by Gerrit Code Review about 7 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30923

#7

Updated by Stig Nørgaard Færch about 6 years ago

So this still means that when inserting a YouTube video, it will not play on Android/IOS?
I just tried it - and that seems to be the case.

#8

Updated by Alexander Opitz almost 6 years ago

  • Target version changed from 4.7.15 to 7.5
#9

Updated by Benni Mack almost 6 years ago

  • Category changed from Content Rendering to 1606
  • Target version deleted (7.5)
#10

Updated by Mathias Schreiber almost 6 years ago

  • Status changed from Under Review to Resolved
#11

Updated by Benni Mack almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF