Bug #53702

Epic #55070: Workpackages

Epic #55065: WP: Overall System Performance (Backend and Frontend)

Bug #52949: Speed decrease since 4.5

FAL fetches storages twice on every BE request

Added by Markus Klein almost 6 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2013-11-16
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

FAL fetches the storages twice on every request.

SELECT COUNT(uid) FROM sys_file_storage WHERE 1=1;
SELECT * FROM sys_file_storage WHERE 1=1 AND sys_file_storage.hidden=0 AND sys_file_storage.deleted=0;

StorageRepository->findAll() tries to detect if there's ever been a storage, and if not so it creates one for /fileadmin.

Maybe this can be optimized somehow to have only one DB access.


Related issues

Related to TYPO3 Core - Story #54266: As an User I want FAL to be performant Closed 2013-11-16 2013-12-31

History

#1 Updated by Alexander Opitz almost 6 years ago

Hi Markus,

as this doesn't happen on fully cached frontend requests, can you write down what types of requests this happen?

#2 Updated by Markus Klein almost 6 years ago

Yes looks like this only happens in the BE.

#3 Updated by Markus Klein almost 6 years ago

  • Subject changed from FAL fetches storages twice on every request to FAL fetches storages twice on every BE request

#4 Updated by Philipp Gampe almost 6 years ago

IMHO this magic create storage stuff should be moved to the install tool as an upgrade wizard.

#5 Updated by Markus Klein almost 6 years ago

  • Parent task set to #52949

#6 Updated by Ingo Schmitt over 5 years ago

  • Status changed from New to Resolved

Was fixed by issue #55186

#7 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF