Project

General

Profile

Actions

Task #53776

closed

Usability: Misleading confirmation dialog when uploading files to filelist

Added by Stefan Aebischer over 10 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2013-11-20
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

When a user uploads files to the filelist, by using the drag'n'drop fileuploader a confirmation message "Shall existing files be overwritten?" appears.
This message is misleading in two ways:

  1. It appears always, even when the uploaded files won't overwrite any existing files
  2. The user is presented the options "Cancel" and "Ok". When pressing "Cancel" the files are uploaded anyway (but no files will be overwritten). IMHO "Cancel" suggests to cancel the whole action
Suggestion to solve the problem
  1. Only ask for confirmation, if at least one of the uploaded files will overwrite an existing file, and display the files which will be overwritten
  2. If the user selects "Cancel", cancel the whole action, and don't upload any files.
  3. If no files will be overwritten, just upload them without disturbing the user.

Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #53222: Filelist --> Upload Files: Shall existing files be overwritten?Closed2013-10-30

Actions
Actions #1

Updated by Gerrit Code Review over 10 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25523

Actions #2

Updated by Markus Klein over 10 years ago

  • Tracker changed from Bug to Task
  • Category set to Backend User Interface
Actions #3

Updated by Gerrit Code Review over 10 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25523

Actions #4

Updated by Gerrit Code Review over 10 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25523

Actions #5

Updated by Stefan Aebischer over 10 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #6

Updated by Thomas Sperling about 10 years ago

As the commit is being reverted (https://git.typo3.org/Packages/TYPO3.CMS.git/commit/a5aed3722d6d512405bcedd200f9686828fdeccb), is there any progress in resolving the problem?

Actions #7

Updated by Markus Klein about 10 years ago

  • Status changed from Resolved to Accepted
  • Target version changed from 6.2.0 to next-patchlevel
Actions #8

Updated by Markus Klein about 10 years ago

We need a better strategy here. I guess we'd need to implement a server side check if a given file will cause an overwrite condition. There's no way to tell that only on the client side.

Actions #9

Updated by Frans Saris about 10 years ago

I created an issue for the UX team maybe they can com up with a replacement for the old checkbox then the problem is also kind of solved. http://forge.typo3.org/issues/55781

Actions #10

Updated by Mathias Schreiber over 9 years ago

  • Target version changed from next-patchlevel to 7.4 (Backend)
Actions #11

Updated by Susanne Moog almost 9 years ago

  • Target version changed from 7.4 (Backend) to 7.5
Actions #12

Updated by Frans Saris almost 9 years ago

  • Status changed from Accepted to Closed

Resolved in TYPO3 7.4 see #55781

Actions

Also available in: Atom PDF