Task #58693

Epic #72584: sysext:impexp

Ignore sys_file_reference records pointing to missing files on import

Added by Marc Bastian Heinrichs over 5 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Category:
Import/Export (T3D)
Target version:
-
Start date:
2014-05-10
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

It could happen, that an export contains sys_file_reference records with relations to sys_files records,
that was missing on the exporting system. This causes exceptions on importing the sys_file_reference records, because on saving of the sys_file_reference record the related sys_file record is checked.

T3D_tree_PID1_L1_2016-01-17_09-02-z.t3d (1.86 KB) Bernhard Kraft, 2016-01-17 10:28

missing-sys-file.xml View (629 KB) Bernhard Kraft, 2016-01-17 10:28


Related issues

Related to TYPO3 Core - Bug #60535: Export referenced files into T3D file when exporting records with file references Closed 2014-07-24
Related to TYPO3 Core - Task #49227: Files missing in import/export Closed 2013-06-18

Associated revisions

Revision f8022ed4 (diff)
Added by Marc Bastian Heinrichs over 3 years ago

[BUGFIX] impexp ignore file reference records with missing related files

It could happen, that an export contains sys_file_reference records
with relations to sys_files records, that was missing in the exporting
instance. This causes exceptions on importing the sys_file_reference
records, because the related sys_file record is checked on saving of
the sys_file_reference record.
To prevent this this sys_file_reference are ignored on import.

Resolves: #58693
Releases: master, 7.6, 6.2
Change-Id: I68afed93502553b0d55eb858bdb6da5641d1e5f0
Reviewed-on: https://review.typo3.org/29994
Reviewed-by: Alexander Opitz <>
Tested-by: Alexander Opitz <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

Revision e623e419 (diff)
Added by Marc Bastian Heinrichs over 3 years ago

[BUGFIX] impexp ignore file reference records with missing related files

It could happen, that an export contains sys_file_reference records
with relations to sys_files records, that was missing in the exporting
instance. This causes exceptions on importing the sys_file_reference
records, because the related sys_file record is checked on saving of
the sys_file_reference record.
To prevent this this sys_file_reference are ignored on import.

Resolves: #58693
Releases: master, 7.6, 6.2
Change-Id: I68afed93502553b0d55eb858bdb6da5641d1e5f0
Reviewed-on: https://review.typo3.org/46523
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

Revision 3af65062 (diff)
Added by Marc Bastian Heinrichs over 3 years ago

[BUGFIX] impexp ignore file reference records with missing related files

It could happen, that an export contains sys_file_reference records
with relations to sys_files records, that was missing in the exporting
instance. This causes exceptions on importing the sys_file_reference
records, because the related sys_file record is checked on saving of
the sys_file_reference record.
To prevent this this sys_file_reference are ignored on import.

Resolves: #58693
Releases: master, 7.6, 6.2
Change-Id: I68afed93502553b0d55eb858bdb6da5641d1e5f0
Reviewed-on: https://review.typo3.org/46524
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

History

#1 Updated by Gerrit Code Review over 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29994

#2 Updated by Marc Bastian Heinrichs over 5 years ago

  • Parent task set to #58777

#3 Updated by Gerrit Code Review over 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29994

#4 Updated by Gerrit Code Review over 5 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29994

#5 Updated by Gerrit Code Review about 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/29994

#6 Updated by Gerrit Code Review almost 4 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/29994

#7 Updated by Anja Leichsenring over 3 years ago

  • Parent task changed from #58777 to #72584

#8 Updated by Anja Leichsenring over 3 years ago

  • Sprint Focus set to On Location Sprint

#9 Updated by Gerrit Code Review over 3 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29994

#10 Updated by Gerrit Code Review over 3 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29994

#11 Updated by Gerrit Code Review over 3 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29994

#12 Updated by Gerrit Code Review over 3 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29994

#13 Updated by Bernhard Kraft over 3 years ago

It would always be nice if the person who reports a bug about and impexp import-issue could supply a .t3d which causes the problem so we can reproduce the problem.

#15 Updated by Gerrit Code Review over 3 years ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29994

#16 Updated by Gerrit Code Review over 3 years ago

Patch set 11 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29994

#17 Updated by Gerrit Code Review over 3 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46523

#18 Updated by Marc Bastian Heinrichs over 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#19 Updated by Gerrit Code Review over 3 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46524

#20 Updated by Marc Bastian Heinrichs over 3 years ago

  • Status changed from Under Review to Resolved

#21 Updated by Mathias Schreiber over 3 years ago

  • Sprint Focus deleted (On Location Sprint)

#22 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF