Bug #61655

Image rescaling breaks/ignores exif orientation

Added by Robotic-Brain no-lastname-given about 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Image Generation / GIFBUILDER
Target version:
-
Start date:
2014-09-16
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The f:image view helper does not seem to respect the exif orientation setting of JPEGs.

When uploading JPEGs taken with some kind of phone (like Android), and using the minHeight/minWidth option of the image view helper, all the images taken in portrait mode get rotated by 90°.

This is really annoying since the only way to fix it is to edit the image, rotate it and remove all exif data.


Files


Related issues

Related to TYPO3 Core - Bug #69274: Portrait Images rotated while file processingClosedStefan Froemken2015-08-24

Actions

Also available in: Atom PDF