Bug #62489

FE : “Desired storage is not in the list of available storages”

Added by Fedir RYKHTIK over 6 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2014-10-27
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

After recreation of "File storage" objects, the Front End doesn't work anymore, "online" link points me [here] : http://wiki.typo3.org/Exception/CMS/1314085990

In BE "fileadmin" folder is browserable, we could read/download files.

Anyone experienced such problem ?

Thx.


Files

Sélection_152.png (57.6 KB) Sélection_152.png Fedir RYKHTIK, 2014-10-27 12:48

Related issues

Is duplicate of TYPO3 Core - Bug #50871: Remove option to delete a File StorageNew2013-08-07

Actions
#1

Updated by Hubertus Golf over 6 years ago

We have same problem after update to V 6.2.6

problem:

if you have files in table sys_file with a storage, that does'nt exist, TYPO3 throws an error.

solution

change field uid in sys_file_storage or field storage in sys_file.

#2

Updated by Alexander Opitz over 6 years ago

@reporter

As I understand you, you removed the file storage and created a new one on the same directory?

#3

Updated by Fedir RYKHTIK over 6 years ago

@Hubertus : Great ! That's it. As in my case it was empty Introduction Package installation, I just made TRUNCATE of sys_file. And error dissapeared, except some missing images in FE.

@Alexander Exactly.

#4

Updated by Christian Ludwig over 6 years ago

We had the same problem.
A solution would be to delete all relations to that storage in the database (including the meta and processed tables) plus the _ processed _ folders. IMHO the original files themselves should not be deleted. Ideal would be a warning if relations to the files / directories on this storage exist in one or more content elements.

#5

Updated by Alexander Opitz over 6 years ago

@Christian

Then you will missing the relations from content elements to the files. Sounds not cool.

@Reporter

To prevent this scenario, I would change this issue in something like: "Do not delete Storage if it contains files." Would this be ok for you? Couse fixing this issue after deletion isn't possible.

#6

Updated by Mathias Schreiber over 6 years ago

  • Sprint Focus set to On Location Sprint
#7

Updated by Mathias Schreiber over 6 years ago

  • Status changed from New to Closed

dupe

#8

Updated by Anja Leichsenring over 5 years ago

  • Sprint Focus deleted (On Location Sprint)
#9

Updated by Gerrit Code Review over 1 year ago

  • Status changed from Closed to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62491

#10

Updated by Andreas Fernandez over 1 year ago

  • Status changed from Under Review to Closed

Also available in: Atom PDF