Project

General

Profile

Actions

Bug #67399

closed

Epic #90674: Backend UI not reflecting permissions

BE editor with rights to edit single locale sees "All" in languages drop-down

Added by Viktor Livakivskyi about 9 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2015-06-10
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi,

We're configuring BE editor groups in a multi-language website. The goal is to give editors access only to those locales, they belong to. This is easily managed by languagess access list in be_groups.
So far so good, until editor wants to create a new record of our custom type.
The usual TCA for our custom records contains such a configuration for sys_language_uid field:

'sys_language_uid' => [
  'exclude' => 1,
  'label' => 'LLL:EXT:lang/locallang_general.xlf:LGL.language',
  'config' => [
    'readOnly' => TRUE,
    'type' => 'select',
    'foreign_table' => 'sys_language',
    'foreign_table_where' => 'ORDER BY sys_language.title',
    'items' => [
      ['LLL:EXT:lang/locallang_general.xlf:LGL.allLanguages', -1],
      ['LLL:EXT:lang/locallang_general.xlf:LGL.default_value', 0]
    ],
  ],
],

So, it is possible to select [All] as language for a record, which is okay for an admin, but not okay for editor, limited to single locale. Due to a fact, that this field is read-only, default selected value is [All], which allows editor to create a new record for all languages, but then he can't edit it due to permissions.

Sure, we can disable readOnly flag and educate editors to select always their language instead of default [All], but this sounds redundantly and still allows editors to set [All], as language.

Current workaround is in adding:

'authMode'    => 'individual',

and
['LLL:EXT:lang/locallang_general.xlf:LGL.allLanguages', -1, '', '', 'EXPL_ALLOW'],

TYPO3 6.2.12

Actions #1

Updated by Riccardo De Contardi about 8 years ago

  • Category set to Backend User Interface
Actions #2

Updated by Peter Linzenkirchner about 8 years ago

I can confirm this for the current dev (8.1.0-dev)

Actions #3

Updated by Riccardo De Contardi over 4 years ago

  • Parent task set to #90674
Actions #4

Updated by Benni Mack almost 3 years ago

  • Status changed from New to Needs Feedback

Sorry for getting to this so late. Can you please confirm this issue is still present in TYPO3 v11 or v10? Due to site handling, this should not be the case anymore in recent versions.

Actions #5

Updated by Christian Kuhn over 2 years ago

  • Status changed from Needs Feedback to Closed

Hey. I hope its ok to close this for now: There hasn't been feedback on this for quite a while and we basically think it's solved with recent versions. Please re-open with more description on current core versions or create a fresh ticket if the issue persists.

Actions

Also available in: Atom PDF