Bug #70044

Typoscript for plugins not being generated when including static templates of fluid_styled_content in external files

Added by Tobias Wollender almost 7 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
TypoScript
Target version:
Start date:
2015-09-23
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

I'm testing out fluid_styled_content and for this deactivated css_styled_content completely. I don't want to include the static template in the backend, but include it in an external typoscript file of my template. Like this:

<INCLUDE_TYPOSCRIPT: source="FILE:EXT:fluid_styled_content/Configuration/TypoScript/Static/setup.txt">

I'm also doing this with the constants of fluid_styled_content. I did this already with css_styled_content too before - without problems. When doing this with fluid_styled_content now, I have problems to add plugins on a page. In the backend this is no problem, but in the frontend I get errors like this:

#1253191023: TypoScript object path "tt_content.list.20.indexed_search" does not exist

Now when I add the static template in the backend, the error is gone and everything is fine. I think there is some generated typoscript missing, when including the static templates in an external file.

#1

Updated by Frans Saris almost 7 years ago

  • Sprint Focus set to Stabilization Sprint
#2

Updated by Benni Mack almost 7 years ago

Hey Tobias,

sounds like the problem of inclusion order of TypoScript. I guess you have the same problem with CSS Styled Content?

#3

Updated by Tobias Wollender almost 7 years ago

Hi Benni,

as I wrote in the description, with css_styled_content everything works as expected. I have an own extension for my templates. In the ext_tables.php I add the static templates:

\TYPO3\CMS\Core\Utility\ExtensionManagementUtility::addStaticFile($_EXTKEY, 'Configuration/TypoScript', 'My Template Configuration');

So I can add them in the Backend. That's the only static template I want to include there. Every other template should be included in e. g. setup.txt like described above. When doing this with css_styled_content everything is fine. With fluid_styled_content the parts like this are missing:

#############################################
## TypoScript added by extension "indexed_search" 
#############################################

When I add it directly in the backend it works. With css_styled_content both ways work. And I just change the path to the templates in this case (and install css_styled_content or fluid_styled_content of course - never both).

Tobi

#4

Updated by Anja Leichsenring almost 7 years ago

Hi Tobias, are you aware of the PageTS fluid_styled_content provides and need to be added to the root page of your instance? Maybe you miss it, and this causes your problem?

See https://docs.typo3.org/typo3cms/extensions/core/latest/Changelog/7.5/Feature-38732-Fluid-basedContentElementsIntroduced.html

#5

Updated by Tobias Wollender almost 7 years ago

Hi Anja,

I also added the PageTS through an include in an external file. But there is only one file in fluid_styled_content for PageTS and it is for the NewContentElementWizard. I included it like this:

<INCLUDE_TYPOSCRIPT: source="FILE: EXT:fluid_styled_content/Configuration/PageTSconfig/NewContentElementWizard.ts">

The defined elements in this file show up correctly after adding it. So I think this is ok. PageTS is also only for backend I think. But the problem for me is in the frontend. Didn't find any other TS files to include in fluid_styled_content.

When adding the static templates in the backend, is there some additional magic happening?

#6

Updated by Jo Hasenau almost 7 years ago

Move the lines including your TS from ext_tables.php to ext_localconf.php and try again :-)

#7

Updated by Tobias Wollender almost 7 years ago

Tried to move this line from ext_tables.php to ext_localconf.php ..

\TYPO3\CMS\Core\Utility\ExtensionManagementUtility::addStaticFile($_EXTKEY, 'Configuration/TypoScript', 'My Template Configuration');

.. but then I can't even select the static template of my extension. So I think ext_tables.php is the right place for this.

#8

Updated by Jo Hasenau almost 7 years ago

Not the static files but the PageTS stuff - somehting similar happens, when you configure Gridelements with external files and include them in ext_tables.php
So it's just a wild guess but it could be the reason.

#9

Updated by Tobias Wollender almost 7 years ago

Yes, I use "\TYPO3\CMS\Core\Utility\ExtensionManagementUtility::addPageTSConfig" in ext_localconf.php already. So I think this should be fine. As stated above I don't do anything different than with css_styled_content and there it works as it should. I uninstall css_styled_content, install fluid_styled_content and adjust the include paths for the static templates in my external file. The standard TS is included - as I can see it in the template analyzer - but the dynamic parts are missing.

#10

Updated by Benni Mack almost 7 years ago

  • Target version changed from 7.5 to 7 LTS
  • Sprint Focus deleted (Stabilization Sprint)
#11

Updated by Daniel Goerz almost 7 years ago

  • Category set to Fluid Styled Content
#12

Updated by Daniel Corn over 6 years ago

Hy! I just want to say that I experience the same problem.

For me this is even a must-have, since it is the only way to create file-based website configurations for modern deployment. Or am I missing another/better way?

#13

Updated by Josef Glatz over 6 years ago

  • Priority changed from Should have to Must have

Would be nice to have this "feature" with FSC

#14

Updated by Markus Klein over 6 years ago

  • Category changed from Fluid Styled Content to TypoScript
  • Status changed from New to Accepted
  • Assignee set to Markus Klein
  • Target version changed from 7 LTS to 7.6.1
  • Complexity set to easy
#15

Updated by Gerrit Code Review over 6 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45080

#16

Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45080

#17

Updated by Markus Klein over 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#18

Updated by Riccardo De Contardi almost 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF