Bug #70449

Story #69617: FormEngine bugs

TCA type group with internal_type folder has been removed

Added by Felix Nagel over 4 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
Start date:
2015-10-06
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

With TYPO3 7.5.0 the TCA config for type group with internal_type folder has been removed.

This is neither documented within the breaking changes docs nor is the description if this feature removed from the core docs. This feature should be restored.

Docs: https://docs.typo3.org/typo3cms/TCAReference/Reference/Columns/Group/Index.html#internal-type
Line: https://github.com/TYPO3/TYPO3.CMS/blob/master/typo3/sysext/backend/Classes/Form/FormDataProvider/TcaGroup.php#L75


Related issues

Related to TYPO3 Core - Bug #72242: Using TCA type group with internal_type folder throws JS errors in backend Closed 2015-12-15

Associated revisions

Revision 0f49e3e0 (diff)
Added by Morton Jonuschat over 4 years ago

[BUGFIX] FormEngine: Fix type=group with internal_type=folder

Restore support for group type fields with internal type of `folder`.

Resolves: #70449
Releases: master
Change-Id: I6cfea6c74c003d64fbbbe7d8904420c757f044d5
Reviewed-on: https://review.typo3.org/44700
Tested-by: Manfred Rutschmann <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>

History

#1 Updated by Benni Mack over 4 years ago

  • Status changed from New to Accepted

Seems to bug due to refactoring. Thanks for the report!

#2 Updated by Christian Kuhn over 4 years ago

  • Parent task set to #69617

#3 Updated by Christian Kuhn over 4 years ago

  • Category set to FormEngine aka TCEforms

#4 Updated by Gerrit Code Review over 4 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44700

#5 Updated by Morton Jonuschat over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF