Bug #76996

Language flags (css classes and sprites) got removed in 7.6.0

Added by Thomas Mayer over 4 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2016-07-09
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

According to the commit message of issue 70477 some deprecations take place for v7 LTS via 7.6.0

https://forge.typo3.org/issues/70477
https://review.typo3.org/#/c/43897/
https://github.com/TYPO3/TYPO3.CMS/commit/58c46d75099acd8449aded959efe8f031cec13d0
https://docs.typo3.org/typo3cms/extensions/core/Changelog/7.6/Deprecation-70477-DeprecateSpriteIconClasses.html

But this commit does more than a deprecation because it also removes files

typo3/sysext/core/Resources/Public/Css/flags.css
typo3/sysext/core/Resources/Public/Images/Sprites/flags.png

And it also removes a bugfix which was merged with 7.4.0

https://forge.typo3.org/issues/68217
https://github.com/TYPO3/TYPO3.CMS/commit/58c46d75099acd8449aded959efe8f031cec13d0#diff-c0eb99ae079c86116b6b94bb0cc1a7beL489

I'd be happy to still be able to support 6.2 with metaseo extension and move to IconRegistry as soon as we drop support for 6.2.
Details: https://github.com/mblaschke/TYPO3-metaseo/issues/257
Our old 6.2-style code is missing css classes for language flags and therefore only displays a red X icon.
We're using the css classes for flags in the backend.

I guess 58c46d75099acd8449aded959efe8f031cec13d0 must at least be considered as a breaking change the way it was done. Is that intended or is it a bug or was there a breaking change in the past (pre-6.2) which allows for the removal of the files?

Removal of flags.css and flags.png was suggested by Wouter Wolters (with a question mark).
A breaking change was suggested by Christian Kuhn (with a question mark) for Patch set 7 of https://review.typo3.org/#/c/43897/ But no breaking change was communicated.

I'm not sure if that was a breaking change, a bug or totally fine. Please give some feedback which was the intention here. For the moment it looks more like a bug to me, while I'm aware that there is a modern alternative in 7.6.x.

Suggested fix would be to give back the dropped files, css classes and bugfix 68217 for 7.6.x only.


Related issues

Related to TYPO3 Core - Task #70477: Deprecate SpriteIcon classesClosedFrank Naegler2015-10-07

Actions
Related to TYPO3 Core - Bug #68217: list view > website language > Flag icons not shownClosed2015-07-16

Actions
Related to TYPO3 Core - Feature #77048: Backend: Embed SVG icons and flags in cssNew2016-07-11

Actions

Also available in: Atom PDF