Bug #80884

FAL metadata has to save multiple times before it's go to the database

Added by Pascal Hinz over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2017-04-19
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I’ve a interesting behavior in TYPO3 7.6 with the FAL metadata. When i try to update the metadata of a file in the FAL List Modul, i have to save the same data multiple times before its go in the database.
How to reproduce:

1. Just open the FAL List Modul
2. Go to a File or Upload a new File
3. Edit the metadata of the file
4. Try to set a alternative text
5. Save
6. Randomly the set text disappeares
7. Retry to set a text and save again and sometimes it saves now sometimes it doesn’t and you have to repeat until its saved

In TYPO3 8 it seems the bug doesn't exists anymore.

Versions: TYPO3 7.6.15 and 7.6.16


Files

TYPO3 Bug 540p.mp4 (3.85 MB) TYPO3 Bug 540p.mp4 Video of the Bug Pascal Hinz, 2017-04-19 08:59

Related issues

Related to TYPO3 Core - Bug #80672: Saving problems in Chrome 57+Closed2017-04-04

Actions
Related to TYPO3 Core - Bug #80366: Values aren't always saved in the TYPO3 backendClosedMarkus Klein2017-03-21

Actions
Related to TYPO3 Core - Bug #80632: still issues with missing input in BEClosed2017-04-02

Actions
Related to TYPO3 Core - Bug #80633: Sending empty forms in some casesClosedFrank Naegler2017-04-02

Actions
#1

Updated by Pascal Hinz over 3 years ago

  • Category set to File Abstraction Layer (FAL)
  • Priority changed from Should have to Must have
#2

Updated by Carsten Hülsmann over 3 years ago

Pascal Hinz wrote:

I’ve a interesting behavior in TYPO3 7.6 with the FAL metadata. When i try to update the metadata of a file in the FAL List Modul, i have to save the same data multiple times before its go in the database.
How to reproduce:

1. Just open the FAL List Modul
2. Go to a File or Upload a new File
3. Edit the metadata of the file
4. Try to set a alternative text
5. Save
6. Randomly the set text disappeares
7. Retry to set a text and save again and sometimes it saves now sometimes it doesn’t and you have to repeat until its saved

In TYPO3 8 it seems the bug doesn't exists anymore.

Versions: TYPO3 7.6.15 and 7.6.16

Same problem here. But in 8.7.0 and 8.7.1.
This also affects the title field of normal content elements (tested most ces)
Already checked php, mysql and typo3 log files. No problems shown up.

#3

Updated by Pascal Hinz over 3 years ago

  • Related to Bug #80672: Saving problems in Chrome 57+ added
#4

Updated by Pascal Hinz over 3 years ago

  • Related to Bug #80366: Values aren't always saved in the TYPO3 backend added
#5

Updated by Pascal Hinz over 3 years ago

  • Related to Bug #80632: still issues with missing input in BE added
#6

Updated by Pascal Hinz over 3 years ago

Bug is also in TYPO3 7.6.18

#7

Updated by Jochen Weiland over 3 years ago

Can confirm that the bug still exists in 7.6.18

Regards
Jochen

#8

Updated by Pascal Hinz over 3 years ago

Tested OS: Mac OS X El Capitan Version 10.11.6 (15G1217)
Tested Browsers:
- Google Chrome Version 57.0.2987.133 (64-bit) <- buggy
- Mozilla Firefox 52.0.2 (64-Bit) <- seems to work, can't reproduce the bug with firefox

#9

Updated by Sebastian Lechenbauer over 3 years ago

I had the same issue in 7.6.18.
Setting the javascript submit timeout in the TBE_EDITOR from 10 to 100 ms solved it for me:
https://github.com/TYPO3/TYPO3.CMS/blob/TYPO3_7-6/typo3/sysext/backend/Resources/Public/JavaScript/jsfunc.tbe_editor.js#L271
See https://review.typo3.org/#/c/52315/

#10

Updated by Markus Klein over 3 years ago

  • Status changed from New to Closed

This shall be resolved with #80633

#11

Updated by Markus Klein over 3 years ago

  • Related to Bug #80633: Sending empty forms in some cases added
#12

Updated by Markus Klein over 3 years ago

Please continue in #80672 if necessary

Also available in: Atom PDF