Bug #80995

Content of hidden page not shown in workspace preview

Added by Oliver Hader about 3 years ago. Updated about 1 month ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Start date:
2017-04-25
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
medium
Is Regression:
Sprint Focus:

Description

New pages in a workspace are created as hidden per default. If either the hidden page or enabled version (the new-placeholder still stays hidden) shall be previewed in the frontend, no content elements are shown.

Parts of previous TYPO3 CMS 7 behavior of PageRepository has been extracted to distinct query restriction interceptors. However, back then not any enable restrictions were not applied if workspaces version preview was active.


Related issues

Related to TYPO3 Core - Bug #85003: Workspace : no content show in preview frontend, if live page is hidden Closed 2018-05-14
Related to TYPO3 Core - Bug #88054: A content element visible in a workspace, is not visibile when it's hidden in LIVE New 2019-04-02
Related to TYPO3 Core - Bug #67001: Workspace Pagepreview doesn't work, if the livepage is set to hidden=1 Accepted 2015-05-17
Related to TYPO3 Core - Bug #82462: Workspace : no content show in preview, for a new page create in workspace, if this page is enable Under Review 2017-09-12

History

#1 Updated by Gerrit Code Review about 3 years ago

  • Status changed from New to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52580

#2 Updated by Gerrit Code Review about 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52580

#3 Updated by Riccardo De Contardi about 3 years ago

related? #80069

#5 Updated by Gerrit Code Review about 3 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52580

#6 Updated by Benni Mack about 3 years ago

  • Target version changed from 8 LTS to next-patchlevel

#7 Updated by Anja Leichsenring almost 2 years ago

  • Status changed from Under Review to New

Olli, how to proceed with the ticket? The patch was abandoned due to lack of feedback.

#8 Updated by Riccardo De Contardi over 1 year ago

  • Related to Bug #85003: Workspace : no content show in preview frontend, if live page is hidden added

#9 Updated by Benni Mack about 1 year ago

  • Target version changed from next-patchlevel to Candidate for patchlevel

#10 Updated by Riccardo De Contardi about 1 month ago

  • Related to Bug #88054: A content element visible in a workspace, is not visibile when it's hidden in LIVE added

#11 Updated by Riccardo De Contardi about 1 month ago

  • Related to Bug #67001: Workspace Pagepreview doesn't work, if the livepage is set to hidden=1 added

#12 Updated by Riccardo De Contardi about 1 month ago

  • Related to Bug #82462: Workspace : no content show in preview, for a new page create in workspace, if this page is enable added

#13 Updated by Riccardo De Contardi about 1 month ago

  • Status changed from New to Closed

I close this issue as a duplicate of #85003 please continue the discussion there.

If you think that this is the wrong decision please reopen it or ping me and I'll do it.

Also available in: Atom PDF