Bug #85003

Workspace : no content show in preview frontend, if live page is hidden

Added by Cristian Buja over 1 year ago. Updated about 1 month ago.

Status:
New
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2018-05-14
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If a live version of a page is hidden, In workspace preview no content is show

TYPO3 Version 8.7 and 9

I think may be related to #82462


Related issues

Related to TYPO3 Core - Bug #82462: Workspace : no content show in preview, for a new page create in workspace, if this page is enable Under Review 2017-09-12
Related to TYPO3 Core - Bug #85742: New page in workspace doesn't load content elements in preview Closed 2018-08-03
Related to TYPO3 Core - Bug #80995: Content of hidden page not shown in workspace preview New 2017-04-25
Related to TYPO3 Core - Bug #67001: Workspace Pagepreview doesn't work, if the livepage is set to hidden=1 Accepted 2015-05-17
Related to TYPO3 Core - Bug #83065: Content is disappearing in Page module in workspaces Closed 2017-11-22
Related to TYPO3 Core - Bug #88054: A content element visible in a workspace, is not visibile when it's hidden in LIVE New 2019-04-02

History

#1 Updated by Riccardo De Contardi over 1 year ago

Maybe is this one? #81731 when I tested it, I was not able to reproduce it AFAICR, but maybe I missed something.
Could you add a step-by-step guide about how to reproduce your issue?

#2 Updated by Cristian Buja over 1 year ago

Riccardo De Contardi wrote:

Maybe is this one? #81731 when I tested it, I was not able to reproduce it AFAICR, but maybe I missed something.

Hum the title issue seems to mean the opposite

Could you add a step-by-step guide about how to reproduce your issue?

Es: 1
- Create a page in live
- hide page
- switch to workspace
- switch hidden page to show
- add contents to page
- No content is view in workspace preview !!!

Es: 2
- Create a new page in live
- add contents to page
- hide page
- switch to workspace
- switch hidden page to show
- No content is view in workspace preview !!!

#3 Updated by Oliver Hader over 1 year ago

  • Related to Bug #82462: Workspace : no content show in preview, for a new page create in workspace, if this page is enable added

#4 Updated by Riccardo De Contardi about 1 year ago

  • Category set to Workspaces

#5 Updated by Riccardo De Contardi 9 months ago

  • Related to Bug #85742: New page in workspace doesn't load content elements in preview added

#6 Updated by Riccardo De Contardi 9 months ago

  • Related to Bug #80995: Content of hidden page not shown in workspace preview added

#7 Updated by Riccardo De Contardi 9 months ago

  • Related to Bug #67001: Workspace Pagepreview doesn't work, if the livepage is set to hidden=1 added

#8 Updated by Riccardo De Contardi 5 months ago

  • Related to Bug #83065: Content is disappearing in Page module in workspaces added

#9 Updated by Riccardo De Contardi 4 months ago

  • Related to Bug #88054: A content element visible in a workspace, is not visibile when it's hidden in LIVE added

#10 Updated by Christian Weiske about 2 months ago

The patch from Gianluca Strafella in https://forge.typo3.org/issues/82462#note-10 solves this issue for us.

#11 Updated by Hannes Bochmann about 1 month ago

The patch from Gianluca Strafella in https://forge.typo3.org/issues/82462#note-10 fixed the problem for us, too. But I'm not sure if the patch is the right way to go. As the page in draft workspace is not hidden it should not be treated like that. I guess there is either a problem when saving data like in #82462 or when fetching page content for the preview.

Also available in: Atom PDF