Bug #82352

Form content element does not ensure "Forms" CType group

Added by Mathias Brodala over 2 years ago. Updated about 1 month ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2017-09-07
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
medium
Is Regression:
Sprint Focus:
Remote Sprint

Description

The form content element is currently placed in the "Forms" CType group but only if EXT:felogin is installed which actually adds this group. Otherwise it ends up in the "Special" group, essential anything which is last in CType.

This probably needs a larger change, e.g. an API to ensure form select field groups are present.

screenshot_with_felogin.png View (62.8 KB) Alexander Stehlik, 2018-10-06 11:19

screenshot_without_felogin.png View (59.5 KB) Alexander Stehlik, 2018-10-06 11:19

Associated revisions

Revision 3da3e5e6 (diff)
Added by Benni Mack about 2 months ago

[FEATURE] Add grouping and sorting for TCA select items

Due to the deprecation of "switchable controller actions", list_type items
can now be grouped in FormEngine - as well as all other "select" fields
defined in TCA.

A new TCA option in TCA type=select is added, called "itemGroups".

In addition, all "items" now have four parts (fourth being optional)
0 => label
1 => value
2 => icon
3 => groupID

where the group belongs to an item group (defined explicitly) or taken
from a --div-- element, which then turns into an optgroup.

In order then to avoid the "itemProcFunc" of tt_content.list_type
which is used to sort items, a "sortOrders" option is added to sort
items (within a group, if grouping is enabled) by label or value.

When registering a new plugin, the groupId can be added as well as an
additional parameter, which falls back to the "default" group.

A new method ExtensionManagementUtility::addTcaSelectItemGroup()
allows to add item groups via API.

When registering extbase Plugins or pibase plugins, it is possible
to add a registered "group ID" to make use of this feature.

Resolves: #91008
Resolves: #82352
Releases: master
Change-Id: I8ad215b5cbc16f332e7c129d762fc020ade5ceeb
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/63889
Tested-by: TYPO3com <>
Tested-by: Georg Ringer <>
Tested-by: Alexander Schnitzler <>
Tested-by: Benni Mack <>
Reviewed-by: Georg Ringer <>
Reviewed-by: Alexander Schnitzler <>
Reviewed-by: Benni Mack <>

History

#2 Updated by Riccardo De Contardi over 1 year ago

As Alexander Stehlik 's screenshots show, the problem is in the CType dropdown; the wizard instead works.

#3 Updated by Christian Eßl 3 months ago

Looks like in TYPO3 10.4.0-dev the "Forms" type is always shown in the "Special" group, even with felogin installed.

#4 Updated by Susanne Moog 3 months ago

  • Category changed from Backend API to Form Framework

#5 Updated by Gerrit Code Review about 2 months ago

  • Status changed from New to Under Review

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63889

#6 Updated by Bjoern Jacob about 2 months ago

  • Sprint Focus set to Remote Sprint

#7 Updated by Gerrit Code Review about 2 months ago

Patch set 11 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63889

#8 Updated by Gerrit Code Review about 2 months ago

Patch set 12 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63889

#9 Updated by Gerrit Code Review about 2 months ago

Patch set 13 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63889

#10 Updated by Gerrit Code Review about 2 months ago

Patch set 14 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63889

#11 Updated by Benni Mack about 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#12 Updated by Benni Mack about 1 month ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF