Bug #83577

Database analyzer: Error message by usage of enums

Added by Jasmina Ließmann about 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-01-16
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
7.1
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

In a project I have enums in the file 'ext_tables.sql'. With #82795 a new behaviour was introduce to my local environment (Windows, Apache + Php 7.1).
When using the database analyzer I get the following error:

Uncaught TYPO3 Exception
Unknown database type enum requested, Doctrine\DBAL\Platforms\MySQL57Platform may not support it. 

Doctrine\DBAL\DBALException thrown in file
###\typo3_src_87\vendor\doctrine\dbal\lib\Doctrine\DBAL\Platforms\AbstractPlatform.php in line 423.

22 Doctrine\DBAL\Platforms\AbstractPlatform::getDoctrineTypeMapping("enum")

Related issues

Related to TYPO3 Core - Bug #82795: Page unavailable handling broken in connectToDB of TypoScriptFrontendController Closed 2017-10-18

Associated revisions

Revision ba5b5242 (diff)
Added by Alexander Stehlik almost 2 years ago

[BUGFIX] Move Doctrine custom type init back to ConnectionPool

To prevent race conditions etc. the custom type init which was moved
in patch https://review.typo3.org/#/c/54512/ gets reverted.

To fix the issue with the pageUnavailable_handling the method
TyposriptFrontendController::connectToDB handles the error correctly via
try catch block.

Change-Id: I4f410d82e54c182d7b032a8ab4486d5b3b859382
Releases: master, 8.7
Resolves: #83577
Related: #82795
Reviewed-on: https://review.typo3.org/55379
Tested-by: TYPO3com <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

Revision c6a630bc (diff)
Added by Alexander Stehlik almost 2 years ago

[BUGFIX] Move Doctrine custom type init back to ConnectionPool

To prevent race conditions etc. the custom type init which was moved
in patch https://review.typo3.org/#/c/54512/ gets reverted.

To fix the issue with the pageUnavailable_handling the method
TyposriptFrontendController::connectToDB handles the error correctly via
try catch block.

Change-Id: I4f410d82e54c182d7b032a8ab4486d5b3b859382
Releases: master, 8.7
Resolves: #83577
Related: #82795
Reviewed-on: https://review.typo3.org/56355
Tested-by: TYPO3com <>
Reviewed-by: Stefan Neufeind <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Jasmina Ließmann about 2 years ago

  • Related to Bug #82795: Page unavailable handling broken in connectToDB of TypoScriptFrontendController added

#2 Updated by Gerrit Code Review about 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55379

#3 Updated by Alexander Stehlik about 2 years ago

Thank you for your report.

I provided a follow up patch that should fix your problem:

Please let me know if this works for you: https://review.typo3.org/55379

#4 Updated by Jasmina Ließmann about 2 years ago

Thanks, that works for me!

#5 Updated by Gerrit Code Review almost 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55379

#6 Updated by Gerrit Code Review almost 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55379

#7 Updated by Joerg Kummer almost 2 years ago

Last patch solves it also for me. Could not open TYPO3 8.7.10 installtool database analyzer and update wizard

#8 Updated by Susanne Moog almost 2 years ago

  • Target version set to 8.7.11
  • Is Regression set to Yes

#9 Updated by Gerrit Code Review almost 2 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55379

#10 Updated by Oliver Hader almost 2 years ago

  • Target version deleted (8.7.11)

#11 Updated by Gerrit Code Review almost 2 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55379

#12 Updated by Alexander Stehlik almost 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#13 Updated by Gerrit Code Review almost 2 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56355

#14 Updated by Alexander Stehlik almost 2 years ago

  • Status changed from Under Review to Resolved

#15 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF