Project

General

Profile

Actions

Bug #84867

closed

Epic #90674: Backend UI not reflecting permissions

Non admin-users aren't able to create IRRE records via the "+" Icon

Added by Webadmin no-lastname-given about 6 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
FormEngine aka TCEforms
Start date:
2018-04-25
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

We have configuered an 1:m IRRE relation with controll icons for each element:

'podcast_episodes' => array(
    'exclude' => 0,
    'label' => 'Mein Feld',
    'config' => array(
        'type' => 'inline',
        'foreign_table' => 'tx_myext_domain_model_podcastepisodes',
        'foreign_field' => 'topic',
        'foreign_sortby' => 'sorting',
        'maxitems'      => 9999,
        'appearance' => array(
            'collapseAll' => TRUE,
            'expandSingle' => TRUE,
            'newRecordLinkAddTitle' => TRUE,
            'newRecordLinkPosition' => 'both',
            'useSortable' => TRUE,
            'enableControls' => array (
                'info' => TRUE,
                'new' => TRUE,
                'dragdrop' => TRUE,
                'sort' => TRUE,
                'hide' => FALSE,
                'delete' => TRUE,
                'localize' => FALSE,
            ),
        ),
    ),
),

For admin users everything works as expected, but if a non-admin users creates a new element via the "+" Icon, he does not have any Icons on these new IRRE Element.

He has to save the parent record first, before he is able to move/delete/hide the new record.

If the non-admin users will use the add button on top or bottom of the IRRE list, it is working too, only the "+" Buttons within the IRRE Records seems to be affected.


Files

Missing Icons.PNG (18.4 KB) Missing Icons.PNG Webadmin no-lastname-given, 2018-04-25 11:08
Normal Add Button.PNG (15.6 KB) Normal Add Button.PNG Webadmin no-lastname-given, 2018-04-25 11:08

Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #91912: Exception when adding nested inline elementsClosed2020-07-31

Actions
Actions #1

Updated by Webadmin no-lastname-given about 6 years ago

  • Assignee deleted (TYPO3 Release Team)
Actions #2

Updated by Benni Mack almost 6 years ago

  • Target version changed from 8.7.13 to 8.7.19
Actions #3

Updated by Susanne Moog over 5 years ago

  • Target version changed from 8.7.19 to Candidate for patchlevel
Actions #4

Updated by Riccardo De Contardi about 4 years ago

  • Parent task set to #90674
Actions #5

Updated by Christian Eßl about 4 years ago

Can't reproduce this in TYPO3 10.4-dev or 9.5.14.
Maybe this has already been fixed. Or I am missing some specific setting here that triggers the error?

Actions #6

Updated by Benni Mack almost 4 years ago

  • Status changed from New to Closed

closing this due to lack of feedback, if you feel this was a wrong decision, let me know, so I will reopen the issue.

Actions #7

Updated by Webadmin no-lastname-given almost 4 years ago

Sorry for the delayed response. We just started this week migration to LTS 10, so I had a chance to test it. Sadly the functionality seems to be completely broken. See https://forge.typo3.org/issues/91912

Actions #8

Updated by Webadmin no-lastname-given almost 4 years ago

  • Related to Bug #91912: Exception when adding nested inline elements added
Actions #9

Updated by Webadmin no-lastname-given over 3 years ago

  • TYPO3 Version changed from 8 to 10
  • PHP Version changed from 7.2 to 7.4

As #91912 is fixed now, we ware able to test this again. But the problem still exists. Even in Typo3 10.4.9

Actions #10

Updated by Benni Mack over 3 years ago

  • Status changed from Closed to Accepted
Actions #11

Updated by Gerrit Code Review over 3 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65999

Actions #12

Updated by Gerrit Code Review over 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65999

Actions #13

Updated by Gerrit Code Review over 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65999

Actions #14

Updated by Gerrit Code Review over 3 years ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/66002

Actions #15

Updated by Oliver Bartsch over 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #16

Updated by Benni Mack over 3 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF