Bug #87068

Use BackendUtility::getPagesTSconfig in TSFE when getting tsconfig

Added by Soren Malling over 1 year ago. Updated 2 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2018-12-04
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Inside the TypoScriptFrontendController the method getPagesTSconfig is used to get the tsconfig from page records. Both via the TSconfig fields but also "included" tsconfig.

The method consist of the same code as BackendUtility::getRawPagesTSconfig (which is called by getPagesTSconfig) - the main difference is, that the frontend method doesn't call emit the signal GetPagesTSconfigPreIncludeSignal to have extensions auto include. So, this gives a different functionality from backend to frontend.

A usecase is inclusion of gridelements layouts. This is used in the frontend for rendering. But when TSFE gets the tsconfig, the signal is not emitted and the tsconfig is not being filled with the layout configuration like it does in the backend

History

#1 Updated by Jo Hasenau about 1 year ago

  • Status changed from New to Accepted
  • Priority changed from Should have to Must have

Since this causes a breaking change between backend and frontend, IMHO that's a must have.

Today someone who had problems using themes with themes_gridelements confirmed that there are no layouts available in the frontend, while they still are in the backend.
So if we are using the same methods here, we have to make sure the corresponding slots are available too.

#3 Updated by Susanne Moog 2 months ago

  • Category set to Frontend

#4 Updated by Benni Mack 2 months ago

  • Status changed from Accepted to Closed

We've reworked the PageTS fetching and parsing logic into several parts now.

Both BackendUtility and TSFE now use a similar logic (but not the same) - as they use a different condition matcher - but have a look at both methods in TYPO3 v10 and see how you can use the new API directly now.

Also available in: Atom PDF