Bug #87751

Performance problem in 9.5.x

Added by Aimeos no-lastname-given over 1 year ago. Updated about 2 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Performance
Target version:
-
Start date:
2019-02-20
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

We still see a massive drop in performance if a non-cachable plugin is placed on a page:
- content and/or cached plugins only: 150ms
- with non-cachable plugin: 450-600ms

Plugins defined as non-cachable in ext_localconf.php:

\TYPO3\CMS\Extbase\Utility\ExtensionUtility::configurePlugin(
    'Aimeos.aimeos',
    'catalog-filter',
    array( 'Catalog' => 'filter' ),
    array( 'Catalog' => 'filter' )
);

Exactly same plugin on a page in TYPO3 8.7 needs 150-200ms.

History

#1 Updated by Benni Mack over 1 year ago

  • Status changed from New to Needs Feedback

Hey Norbert,

so you're saying:

8.7 with cached plugin 150-200ms.
8.7 with non-cached plugin 150-200ms

9.5 with cached plugin 150-200ms.
9.5 with non-cached plugin 450-600ms
?

#2 Updated by Aimeos no-lastname-given over 1 year ago

Yes, exactly

#3 Updated by Riccardo De Contardi over 1 year ago

  • Status changed from Needs Feedback to New

#4 Updated by Alexander Schnitzler 12 months ago

Aimeos no-lastname-given wrote:

Yes, exactly

Hi Norbert,
do you have anything at hand to reliably prove/support that statement? Like a blackfire.io comparison or some other kind of benchmark?

Not that I don't believe you but it would be great to have a hint about what exactly causes this in the core.

#5 Updated by Georg Ringer 8 months ago

  • Status changed from New to Needs Feedback

#6 Updated by Benni Mack about 2 months ago

  • Status changed from Needs Feedback to Closed

Closing this issue due to lack of feedback for the last 90 days. Norbert, if you have more information, let me know so I can re-open the ticket.

Also available in: Atom PDF