Project

General

Profile

Actions

Bug #88831

closed

Problems with the fallback settings in sites config

Added by Lars Lüthi almost 5 years ago. Updated 6 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
Start date:
2019-07-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

We have problems with the fallback settings in the sites config. We develop a website for a customer with over 70 sys_languages (0 = en_CH, 1 = de_CH, 2 = de_DE ...). But there are only 5 “real” languages. So for easy content maintaining, we want to have all extbase records only 5 times (they have a lot of products and references). Actually we have the translations for 3 languages (EN,DE,FR)

Maybe we misunderstood something but shouldn’t it be possible to configure another fallback language for each sys_language so we can show as example the german content on both the Swiss and the Germany version of the website? The content is created with the Switzerland German sys_language but in the Germany version the content is shown in english (default language 0). We actually don't know if this is a bug or we have something wrong in our configuration. We have 9.5.8 installed.

Here is a shortened example from our sites config.

-
title: ‘Switzerland (CH), English (Default)’
enabled: true
languageId: ‘0’
base: /ch-en/
typo3Language: default
locale: en_CH
iso-639-1: en
navigationTitle: ‘’
hreflang: en-CH
direction: ‘’
flag: ch
-
title: ‘Switzerland (CH), German (Default)’
enabled: true
languageId: ‘1’
base: /ch-de/
typo3Language: de
locale: de_CH
iso-639-1: de
navigationTitle: ‘’
hreflang: de-CH
direction: ‘’
fallbackType: fallback
fallbacks: ‘0’
flag: ch
-
title: ‘Germany (DE), German’
enabled: true
languageId: ‘2’
base: /de-de/
typo3Language: de
locale: de_DE
iso-639-1: de
navigationTitle: ‘’
hreflang: de-DE
direction: ‘’
fallbackType: fallback
fallbacks: ‘1,0’
flag: de

If you need more information please tell me. Any help or hint is very welcome :-)


Files

Actions #1

Updated by Susanne Moog almost 5 years ago

  • Target version set to next-patchlevel
Actions #2

Updated by Thomas Anders over 4 years ago

Seems to be the same problem as the one I just stumbled across.

I'm using "German AT"(default) and "German DE"(second language)

In Connected Mode I can translate everything and the translation is correctly shown for DE.
Using Copy-mode leads to an untranslated page. If I create content in DE only, it is never shown.

Heres the siteconfig:

base: 'https://domain.at/'
baseVariants: {  }
errorHandling: {  }
languages:
  -
    title: 'Deutsch AT'
    enabled: true
    base: 'https://domain.at/'
    typo3Language: default
    locale: da_AT.UTF8
    iso-639-1: de
    navigationTitle: 'Deutsch AT'
    hreflang: de-AT
    direction: ''
    flag: at
    languageId: '0'
  -
    title: 'Deutsch DE'
    enabled: true
    base: 'https://domain.de/'
    typo3Language: de
    locale: de_DE.UTF8
    iso-639-1: de
    navigationTitle: 'Deutsch DE'
    hreflang: de-DE
    direction: ''
    fallbackType: fallback
    fallbacks: '0'
    flag: de
    languageId: '1'
rootPageId: 1
routes: {  }

Maybe someone knows a temporary solution until this is solved?

Actions #3

Updated by Ralf Tönjes over 4 years ago

Same here. The fallbacks directive is ignored and the default language is always shown.

Actions #4

Updated by Johannes Rebhan almost 4 years ago

Same problem as Lars. We tried basically the same they did. Create 4 "base languages" and use the language variants with fallbacks to one of those 4 base languages. The settings in sites.config are simply ignored.

Example:

1. Base language EN
2. Second language DE (strict, no fallback language defined)
3. Third language DE-AT (fallback, DE is fallback language)

Result:
EN is shown. If we switch to strict in DE-AT the page is empty. We've tried all possible combination of using the defined sites.config fallback languages, with strict, free, fallback mode, different languages etc. they are always ignored. If fallback is activated it always goes to the base language as fallback source, just like it did in TYPO3 < 9. This also applies to version 10. Is there any way this feature introduced years ago in 9 does anything noticeable? Or what is the supposed function of defining fallback languages if they are not used for... fallback?

Actions #5

Updated by Benni Mack about 1 year ago

  • Status changed from New to Needs Feedback

We've finally added this feature (multi-level fallback) in TYPO3 v12.0 - can you recheck if something is missing?

Actions #6

Updated by Christian Kuhn 6 months ago

  • Status changed from Needs Feedback to Closed

Hey. I hope it's ok to close here since we worked on this in v12. Let's have a fresh issue in case we missed something.

Actions

Also available in: Atom PDF