Project

General

Profile

Actions

Bug #88858

open

Richtext configuration set in a flexform gets overwritten by RTE.default.preset

Added by Jan Kornblum over 4 years ago. Updated almost 4 years ago.

Status:
Accepted
Priority:
Should have
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2019-07-30
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
rte
Complexity:
Is Regression:
Sprint Focus:

Description

A richtext configuration is set in a flexform (attached to pi_flexform) field:

<settings.anyRichtextField>
    <exclude>1</exclude>
    <label>Custom RTE enabled field</label>
    <config>
        <type>text</type>
        <rows>5</rows>
        <cols>30</cols>
        <eval>trim,required</eval>
        <enableRichtext>1</enableRichtext>
        <richtextConfiguration>custom_config</richtextConfiguration>
    </config>
</settings.anyRichtextField>

As long as no global RTE preset is set anywhere else, the configuration is loaded fine. But as soon as...

RTE.default.preset = minimal

...is set anywhere else, the per-flexform-field rte configuration gets ignored. Also, it is not possible to explicitly set the preset by tsconfig like this additionally...

TCEFORM.[tableName].[fieldName].[dataStructureKey].[flexSheet].[flexFieldName].[propertyName] 

...due to limitations of the "config" section mentioned here: https://docs.typo3.org/m/typo3/reference-tsconfig/master/en-us/PageTsconfig/TceForm.html


Related issues 2 (1 open1 closed)

Related to TYPO3 Core - Bug #88655: richtextConfiguration, set via TCA for a text field is ignoredClosed2019-06-29

Actions
Related to TYPO3 Core - Feature #91690: Override Flexform via Page TsConfigNew2020-06-22

Actions
Actions

Also available in: Atom PDF