Bug #13056

admin users see all changes in LIVE workspace

Added by Riccardo De Contardi almost 11 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Workspaces
Target version:
-
Start date:
2011-02-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I've made a configuration like this:

an "editors" group
-a "reviewers & publishers" group (has got "Live" access)
a custom workspace
- owner: reviewers & publishers
- members: editors

No "workspace stage" records, as I want a very very simple workflow: the only step after editing should be "send to ready to publish"

When I am an admin user and I go to workspaces module (in LIVE), I still see all the changes done (i.e. all the changes occurred to the content element I've changed) with current stage: "editing" and the "Discard workspace version of record" button does not seem to work.

(Maybe related to 11535?)


Files

C6.PNG (17.3 KB) C6.PNG Riccardo De Contardi, 2011-02-24 11:24
C7.PNG (21.6 KB) C7.PNG Riccardo De Contardi, 2011-02-24 11:24
c1.PNG (26.1 KB) c1.PNG Riccardo De Contardi, 2011-02-24 11:24
C2.PNG (20.7 KB) C2.PNG Riccardo De Contardi, 2011-02-24 11:24
C3.PNG (23.4 KB) C3.PNG Riccardo De Contardi, 2011-02-24 11:24
C4.PNG (23.8 KB) C4.PNG Riccardo De Contardi, 2011-02-24 11:24
C5.PNG (12.4 KB) C5.PNG Riccardo De Contardi, 2011-02-24 11:24
20130328_c6.PNG (48.6 KB) 20130328_c6.PNG Riccardo De Contardi, 2013-03-28 11:13
20130328_c7.PNG (16.6 KB) 20130328_c7.PNG Riccardo De Contardi, 2013-03-28 11:13
20130328_c8.PNG (38.1 KB) 20130328_c8.PNG Riccardo De Contardi, 2013-03-28 11:13
20130328_c1.PNG (30.4 KB) 20130328_c1.PNG Riccardo De Contardi, 2013-03-28 11:13
20130328_c2.PNG (38.7 KB) 20130328_c2.PNG Riccardo De Contardi, 2013-03-28 11:13
20130328_c3.PNG (45.5 KB) 20130328_c3.PNG Riccardo De Contardi, 2013-03-28 11:13
20130328_c4.PNG (47.7 KB) 20130328_c4.PNG Riccardo De Contardi, 2013-03-28 11:13
20130328_c5.PNG (50.2 KB) 20130328_c5.PNG Riccardo De Contardi, 2013-03-28 11:13

Related issues

Related to TYPO3 Core - Bug #89122: Inconsistent evaluation of pid=-1 with workspace recordsClosedBenni Mack2019-09-112019-09-11

Actions
Related to TYPO3 Core - Bug #91983: Drop 'Live workspace' tab from workspace moduleClosed2020-08-11

Actions
Has duplicate TYPO3 Core - Bug #34329: LIVE Workspace behavior after publishingClosed2012-02-27

Actions
#1

Updated by Tolleiv Nietsch almost 11 years ago

  • Status changed from New to Accepted
#2

Updated by Riccardo De Contardi almost 11 years ago

The bug is still present in T3 4.5.1
I'd like to add some infos and screenshots: here is the procedure I followed:

STEP 1: editing
1. Enter with editor user (can work only in custom workspace)
1.1 Modify a CE (see C1.PNG, the text added is BBBBBB)
1.2 In workspaces module: see C2.PNG
1.2.1 Click on the green arrow "send record to next stage" (alternatively, I check the checkbox, then in the dropdown "choose action" the only choiche is "Send to stage: ready to publish".
I don't have recipients or comments to write, so I click "OK" on the popup.
1.2.2 see C3.PNG

STEP 2: publishing
2.Enter with publisher user (can work in custom workspace and LIVE)
2.1 in workspace module: C4.PNG
2.1.1 Click on the green arrow "send record to next stage" and then OK on the popup. Result: see C5.png

NOTE: if i check the checkbox, the dropdown "choose action" has 3 choiches:
."Send to stage: ready to publish" (WHY?? Again??)
."Publish to LIVE"
."Send to stage:editing"

STEP 3: enter as admin
3. Enter with admin user and go to LIVE workspace
3.1 in workspace module: C6.PNG
NOTE: in custom workspace I don't see anything, as in C5.PNG
3.2 If I click on green arrow, the result is C7.PNG; if I click again on the green arrow, it returns tu 3.1

Thank you for your support

BTW: what does

Current stage step: Editing n/3

means exactly?

#3

Updated by Oliver Hader over 10 years ago

  • Target version changed from 4.5.1 to 4.5.3
#4

Updated by Oliver Hader over 10 years ago

  • Target version changed from 4.5.3 to 4.5.3
#5

Updated by Oliver Hader over 10 years ago

  • Target version changed from 4.5.3 to 4.5.3
#6

Updated by Tolleiv Nietsch over 10 years ago

  • Target version changed from 4.5.3 to 4.5.4
  • TYPO3 Version set to 4.5
#7

Updated by Riccardo De Contardi over 9 years ago

A customer asked me an update on this topic.
Thank you very much and best regards.

#8

Updated by Riccardo De Contardi over 9 years ago

This bug is still present in TYPO3 4.7.0

#9

Updated by Riccardo De Contardi over 8 years ago

This bug is still present in TYPO3 6.0.4!

#10

Updated by Andreas Wolf over 8 years ago

  • Target version changed from 4.5.4 to 6.0.5

@Riccardo: First of all, I'm sorry that nobody really took care of this issue for such a long time. I'm raising the target version now to the next 6.0 version, so maybe we can finally get this solved.

Two questions:

  1. What does the editor see in the workspaces module after the content has been published? Is the module empty or does it also display the content?
  2. Did you really choose "publish" or rather "swap" (I don't know if that option still exists, I'm not that firm with workspaces). Anyways, if you did not, then this is clearly a bug; if you swapped the versions (accidentially or on purpose), this is the intended behaviour.
#11

Updated by Andreas Wolf over 8 years ago

  • Status changed from Accepted to Needs Feedback
#12

Updated by Riccardo De Contardi over 8 years ago

Ok... this is the procedure I've followed

1. Groups - the following groups were created:
administrators (ID=1) - only to group administrators
ws_t3_permission (ID=2) - all pages belong to this group
ws_t3_create_edit (ID=3) - this group has access list configured
ws_t3_mount[home] (ID=4) - this group has db mount (home,ID=1) and file mounts configured
ws_t3_create (ID=5) - subgroups: ws_t3_permission, ws_t3_create_edit, ws_t3_mount[home]
ws_t3_review (ID=6) - subgroups: ws_t3_permission, ws_t3_create_edit, ws_t3_mount[home],ws_t3_create
ws_t3_publish (ID=7) - subgroups: ws_t3_create, ws_t3_review: Workspace permissions: Edit Live (Online) (it is the only group with this option checked)

2. Users - the following users were created:
administator (ID=609); is admin --> group:adminstrators
t3editor(ID=610); inherits DB mount, file mounts from group, edit live (Online):NO --> group: ws_t3_create
t3reviewer(ID=612); inherits DB mount, file mounts from group,edit live (Online):NO --> group: ws_t3_review
t3publisher (ID=614); inherits DB mount, file mounts from group,edit live (Online):NO --> group: publish

3. Workspace: the following workspace was created:
t3_draft(ID=1)
Owners: administators, ws_t3_publish
Members: ws_t3_create, ws_t3_review
Custom stages: Approval by reviewers; responsible persons: ws_t3_review, ws_t3_publish

All others options were left as default when a workspace is created.

4.TEST CASES

4.1 editing of an existing CE
4.1.1 - STEP 1: editing
4.1.1.1 Log in as t3editor and modify a CE (see 20130328_c1.PNG, the text added is BBBBBB), save
4.1.1.2 in workspace module: see 20130328_c2.PNG; when I check the CE the only option in the first dropdown below is "send to stage "Approval by reviewers" "
4.1.1.3 I click on the right green arrow to send the CE to the next step; I don't have recipients or comments to write, so I click "OK" on the popup.
4.1.1.4 Result: see 20130328_c3.PNG

4.1.2 - STEP 2: review
4.1.2.1 Log in as t3reviewer and go to the workspace module: see 20130328_c4.png; when I check the CE the options in the first dropdown below
are the ones you see in the attached file (QUESTION: isn't an error to show "send to stage "Approval by reviewers""?)
4.1.2.2 I click on the right green arrow to send the CE to the next step; I don't have recipients or comments to write, so I click "OK" on the popup.
4.1.2.3 Result: see 20130328_c5.PNG

As far as now, if I enter as administrator, the LIVE tab of the workspace module is empty
4.1.3 - STEP 3: publish
4.1.3.1 Log in as t3publisher and go to the workspace module: see 20130328_c6.png; when I check the CE the options in the first dropdown below
are the ones you see in the attached file (QUESTION: isn't an error to show "send to stage "Ready to publish"" ?)
4.1.3.2 I click on the right green arrow to send the CE to the next step; I don't have recipients or comments to write, so I click "OK" on the popup.
4.1.3.3 Result: see 20130328_c7.PNG

4.1.4 - enter as administrator, go to workspace module; the result is shown in 20130328_c8.PNG
as you can see there is nothing that can be done here; please note that the "t3_draft" tab is empty

I hope that this will be sufficient; please contact me if you need more infos

#13

Updated by Riccardo De Contardi over 8 years ago

Still present in 6.1...

#14

Updated by Ehringer, Christian about 8 years ago

Riccardo De Contardi wrote:

Still present in 6.1...

Also Present in 4.7.7

#15

Updated by Michael Stucki almost 8 years ago

  • Category changed from Bugs to Workspaces
#16

Updated by Michael Stucki almost 8 years ago

  • Project changed from 624 to TYPO3 Core
  • Category changed from Workspaces to Workspaces
#17

Updated by Alexander Opitz over 7 years ago

  • Status changed from Needs Feedback to New
  • Target version deleted (6.0.5)
  • Is Regression set to No
#18

Updated by Sascha Schieferdecker about 7 years ago

Still present in 6.2.6 and really confusing

#19

Updated by Mathias Schreiber almost 7 years ago

  • Target version set to 7.5
#20

Updated by Benni Mack about 6 years ago

  • Target version changed from 7.5 to 7 LTS
#21

Updated by Mathias Schreiber about 6 years ago

  • Target version deleted (7 LTS)
#22

Updated by Oliver Hader over 5 years ago

  • Assignee set to Oliver Hader
  • Priority changed from Must have to Should have

... will have a look, the query to select records for the backend workspace module seems to be incomplete (not filtering out published version records - which are still in the database, but disabled)

#23

Updated by Riccardo De Contardi over 5 years ago

I can say the issue is still present on 8.1.1-dev (latest master); to reproduce it quickly:

1) create a workspace "custom workspace"
2) go to custom workspace and edit a content element, save
3) go to workspace module and publish the changes
4) on workspace module > LIVE tab you should see the issue.

#24

Updated by Riccardo De Contardi almost 5 years ago

Just checked. Still present on 8.6-dev (latest master)

#25

Updated by Steffen G/G over 3 years ago

Why is this not fixed yet? Seems only to be a little fix.

#26

Updated by Benni Mack over 2 years ago

It basically shows the "archived" records.

#27

Updated by Benni Mack almost 2 years ago

Riccardo, I believe this is now fixed in TYPO3 v10 now? At least in FE. For BE we need to investigate and double-check.

#28

Updated by Riccardo De Contardi almost 2 years ago

  • TYPO3 Version changed from 4.5 to 9

Benni Mack, I always tested just the backend module; from a quick test (same as my test on comment 23) I can say that:

  • The issue is still present on version 9.5.13
  • The issue is not present on the latest master (10.3.0-dev)

this is why I raise the version to 9

#29

Updated by Boris Schauer over 1 year ago

The issue is still present on version 9.5.14

#30

Updated by Christian Kuhn over 1 year ago

  • Status changed from New to Closed

The issue has been fixed in v10 and is not fixed in v9.

The main query that fetches the rows (WorkspaceService->selectAllVersionsFromPages()) has been adapted with the pid=-1 removal patch #89122 in a way that it can't show records any longer if the "Live workspace" tab is selected. The bogus rows shown before are gone. Actually, the Live workspace tab now never shows any rows as far as I understand (with the bogus rows gone, nothing is left).

In v9, the query restrictions include pid=-1 rows without t3ver_oid check, so the "Live workspace" tab shows those bogus rows. However, the query is a quite complex self-join and fiddling with the query in v9 adds a relatively high chance to introduce new issues. Since v9 is in 'critical bugs only' mode, and this issue is not critical, I'd opt to skip a bugfix for v9.

-> I'll close the issue as 'has been resolved' now. Furthermore, we should drop the 'Live workspace' tab altogether since it can't show any records anyways. This will be a new issue, though.

#31

Updated by Christian Kuhn over 1 year ago

  • Related to Bug #89122: Inconsistent evaluation of pid=-1 with workspace records added
#32

Updated by Christian Kuhn over 1 year ago

  • Related to Bug #91983: Drop 'Live workspace' tab from workspace module added

Also available in: Atom PDF