Bug #20502

MYSQL Replication breaks because of lack of AUTO_INCREMENT PK in cache_treesection

Added by Lukas Taferner almost 11 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Caching
Target version:
-
Start date:
2009-05-25
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Thank you for implementing auto_incrementing PK's in cache_pages and cache_pagesection in 4.3, the table cache_treelist however still has a md5 hash as primary key. This will break replication in a multimaster mysql setup.

Solution:
CREATE TABLE `cache_pages` (
`id` int(11) unsigned NOT NULL auto_increment,
PRIMARY KEY (`id`)
)

(issue imported from #M11184)


Related issues

Related to TYPO3 Core - Bug #20065: MYSQL Replication breaks because of lack of AUTO_INCREMENT PK in cache_pagesection Closed 2009-02-20

History

#1 Updated by Oliver Hader over 10 years ago

Lukas, could you please send me your MySQL Server and Replication settings?
Are there two MySQL Masters running and replicating at the same time in your scenario?

#2 Updated by Lukas Taferner over 10 years ago

Hi Oliver, we have a setup with multiple MySQL Masters with crossreplication i.e. every write operation is replicated to all the other DB hosts. We could have chosen to set caching to 5 min. and exclude cache* from replication, but it's better to be able to clear the cache on the livebackend (and replicate this to the other hosts) in realtime.

#3 Updated by Lukas Taferner over 10 years ago

Oliver, can you please take care that the issue will be fixed :)
Please check my comment @ #0010508

#4 Updated by Dmitry Dulepov almost 10 years ago

Same for cache_imagesizes.

#5 Updated by Alexander Opitz almost 7 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#6 Updated by Chris topher almost 7 years ago

  • Status changed from Needs Feedback to New

Alexander Opitz wrote:

does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

Table "cache_treesection" does not exist anymore in current versions.

The problem however is still present for the table "cache_imagesizes".

#7 Updated by Thorsten Kahler almost 7 years ago

The problem exists for all MM relation tables, too.

#8 Updated by Michiel Roos about 6 years ago

Problem still present in 4.5 too.

#9 Updated by Riccardo De Contardi almost 5 years ago

  • TYPO3 Version changed from 4.3 to 6.2
  • Is Regression set to No

Problem is still present in 6.2 (I mean, about cache_imagesizes)

#10 Updated by Wouter Wolters over 4 years ago

In 7.x cache_imagesizes is ported to the caching framework.

#11 Updated by Georg Ringer over 4 years ago

  • Status changed from New to Resolved

resolved as mentioned about the caching framework

#12 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF