Bug #24075

Not possible to configure RTE for flexform fields

Added by Lars Houmark about 7 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2010-11-16
Due date:
% Done:

0%

TYPO3 Version:
4.4
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When loading a RTE inside a flexform, it can be convenient to configure the RTE for the needed buttons etc.

At the moment configuration added to <defaultExtras> is not interpreted, thus making it impossible to hide buttons not wanted.

The attached patch fixes the problem and does it without interrupting Page TS configurations and User TS configurations.
(issue imported from #M16413)

16413.diff View (1.01 KB) Administrator Admin, 2010-11-16 09:58

16413-v.2.diff View - Patch 16413-v.2 for the Bug #24075 (950 Bytes) Fedir RYKHTIK, 2011-12-22 15:21

FormEngine.php.patch View (737 Bytes) Witali Rott, 2014-06-02 09:34


Related issues

Related to TYPO3 Core - Bug #66803: RTE defaultExtras doesn’t work in IRRE mode Resolved 2015-05-05
Duplicated by TYPO3 Core - Bug #21815: Form extras don't work with Richtext Closed 2009-12-07

History

#1 Updated by Lars Houmark about 7 years ago

The patch is made for the 4.4 branch but does apply for both 4.3 and trunk with a minor offset and thus it should be applied for all 3 branches.

#2 Updated by Stanislas Rolland about 7 years ago

The question is: are the buttons specified in defaultExtras shown in the RTE even if they are not present in the default configuration?

defaultExtras cannot be used to hide buttons included in the default configuration. It can only be used to add buttons "on top of" those specified in the default configuration.

See: http://typo3.org/documentation/document-library/core-documentation/doc_core_api/4.3.0/view/4/3/#id2531282

#3 Updated by Marco Malagoli almost 7 years ago

IMHO this patch is very useful and I hope it will be integrated in futur version.
Cheers.

#4 Updated by Fedir RYKHTIK about 6 years ago

2 Stanislas Rolland :

+1 We definitively need such feature. For example, we could hide some extrabuttons in the flexform with following construction :

<defaultExtras>richtext[bold|italic|subscript|superscript|removeformat|chMode]:rte_transform[flag=rte_enabled|mode=ts_css]</defaultExtras>

The patch could be applied on 4.5 and 4.6 branches, the issue is still present.

The actual version of the document You referenced is situated here : http://typo3.org/documentation/document-library/core-documentation/doc_core_tca/4.6.0/view/1/4/

" Default Special Configuration (defaultExtras)

Since "types"-configuration does not apply for FlexForms and since a feature available as special configuration is sometimes needed regardless of type value you can also configure the default value of the special configuration. This is done with a key in the ['columns'][field name] array. Thus, the alternative configuration for the example above could be: "

If You have any questions, please ask.

#5 Updated by Fedir RYKHTIK about 6 years ago

That's an another version of the patch, there we could see more clearly, what we are using local configuration instead of default one. Patch made on 4.5.10.

#6 Updated by Tizian Schmidlin about 5 years ago

Is there a chance that this patch gets into core anyday soon? I almost lost a day looking for what the issue mitgh be until I found this bug report (btw, thank you for the patch).

#7 Updated by Alexander Opitz over 4 years ago

  • Status changed from Needs Feedback to New
  • Target version deleted (0)

#8 Updated by Alexander Opitz over 4 years ago

  • Category set to RTE (rtehtmlarea + ckeditor)

#9 Updated by Alexander Opitz over 4 years ago

  • Assignee set to Alexander Opitz

#10 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/21474

#11 Updated by Gerrit Code Review over 4 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/21477

#12 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/21474

#13 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/21477

#14 Updated by Gerrit Code Review over 4 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/21477

#15 Updated by Christian Buelter about 4 years ago

Patch v2 works for me for TYPO3 CMS 4.5.32 (although I had to apply it manually).

#16 Updated by Alexander Opitz about 4 years ago

  • Status changed from Under Review to Accepted
  • Is Regression set to No

#17 Updated by Stefan Neufeind almost 4 years ago

What's the status of this? Where is it going? I see there was a patch for master but now abandoned?!?

#18 Updated by Witali Rott over 3 years ago

The Patch reset the whole config.
Use this Patch to change only the Buttons.
Works under 6.0.13

#19 Updated by Alexander Opitz over 2 years ago

  • Category changed from RTE (rtehtmlarea + ckeditor) to 1600

#20 Updated by Benni Mack almost 2 years ago

  • Category changed from 1600 to RTE (rtehtmlarea + ckeditor)
  • Status changed from Accepted to Closed

We fixed this in v7, works just fine in the styleguide extension.

If I set

RTE.default.showButtons = image

then only the image button shows up.

My defaultExtras section then contains this:

<defaultExtras>richtext[*]:rte_transform</defaultExtras>

and everything works. Finally we fixed it.

Also available in: Atom PDF