Task #36420

Epic #55070: Workpackages

Epic #54260: WP: FAL Missing Issues / Features / API

Story #54264: As an Enterprise User I want to use Storages outside my webroot or on remote systems in order to structure my Files according to my IT-Guidelines

Filemount in local file system (not on webserver) leads to errors

Added by Susanne Moog almost 8 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2012-04-22
Due date:
% Done:

100%

Estimated time:
12.00 h
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
medium
Sprint Focus:

Description

I have a filemount set to /home/susanne/test, my web server is running at /var/www/sd/. Trying to access the storage results in "#1329765518: Public URL of file cannot be determined", how could I tell the system where to find the public url? (as it clearly cannot be automatically found with a folder "somewhere" and "magic conf" to access it.


Related issues

Related to TYPO3 Core - Bug #56927: Regression: baseUri for LocalDriver is invalid for fallback storage Closed 2014-03-15
Related to TYPO3 Core - Bug #60294: If a local file storage is outside the document root, images are sometimes not shown if multiple images are on a page. Closed 2014-07-13
Related to TYPO3 Core - Bug #61295: calculateBasePath of LocalDriver does not properly sanitize value Closed 2014-09-01
Duplicated by TYPO3 Core - Task #54227: Fix Storages outside web-root Rejected 2013-12-06
Blocked by TYPO3 Core - Task #35858: Test and fix URL generation Closed 2012-04-11

Associated revisions

Revision 64838420 (diff)
Added by Steffen Ritter almost 6 years ago

[FEATURE] Allow Storages outside the webroot

Storages can be marked as not public or be outside of webroot.
There are no direct links to the files posible.

This change adds a eID implementation to create urls to these files.
It also implements a hook in het eID dispatcher that makes is possible
to add custom security/access checks when delivering files.

Releases: 6.2
Resolves: #36420
Change-Id: Ie7fc9c8a674a3200ea2b29d1adc17327d10bd6e5
Reviewed-on: https://review.typo3.org/27760
Reviewed-by: Frans Saris
Tested-by: Frans Saris
Reviewed-by: Fabien Udriot
Tested-by: Fabien Udriot
Reviewed-by: Steffen Ritter
Tested-by: Steffen Ritter

History

#1 Updated by Ingmar Schlecht almost 8 years ago

  • Target version set to 6.0 beta1

#2 Updated by Andreas Wolf over 7 years ago

  • Status changed from New to Accepted
  • Assignee set to Andreas Wolf

This is currently an open issue - there is no configuration option for the public URL.

#3 Updated by Andreas Wolf over 7 years ago

  • Project changed from File Abstraction Layer to TYPO3 Core
  • Target version deleted (6.0 beta1)

#4 Updated by Andreas Wolf over 7 years ago

  • Category set to File Abstraction Layer (FAL)
  • TYPO3 Version set to 6.0

#5 Updated by Andreas Wolf over 7 years ago

Andreas Wolf wrote:

This is currently an open issue - there is no configuration option for the public URL.

More specifically, the option is there (baseUri), but not configurable in TCA.

#6 Updated by Steffen Ritter about 6 years ago

  • Parent task set to #54264
  • Is Regression set to No

#7 Updated by Steffen Ritter about 6 years ago

  • Assignee deleted (Andreas Wolf)
  • TYPO3 Version changed from 6.0 to 6.2

#8 Updated by Steffen Ritter almost 6 years ago

  • Assignee set to Steffen Ritter

#9 Updated by Steffen Ritter almost 6 years ago

  • Tracker changed from Bug to Feature
  • Target version set to 6.2.0

#10 Updated by Steffen Ritter almost 6 years ago

  • Priority changed from Should have to Must have
  • Estimated time set to 12.00 h
  • Complexity set to medium

#11 Updated by Gerrit Code Review almost 6 years ago

  • Status changed from Accepted to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27760

#12 Updated by Steffen Ritter almost 6 years ago

  • % Done changed from 0 to 50

#13 Updated by Gerrit Code Review almost 6 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27760

#14 Updated by Gerrit Code Review almost 6 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27760

#15 Updated by Gerrit Code Review almost 6 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27760

#16 Updated by Gerrit Code Review almost 6 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27760

#17 Updated by Gerrit Code Review almost 6 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27760

#18 Updated by Gerrit Code Review almost 6 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27760

#19 Updated by Gerrit Code Review almost 6 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27760

#20 Updated by Gerrit Code Review almost 6 years ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27760

#21 Updated by Steffen Ritter almost 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 50 to 100

#22 Updated by Xavier Perseguers almost 6 years ago

  • Status changed from Resolved to Needs Feedback

Using git bisect I came to this patch breaking my Frontend output. Comment from gerrit:

Post -1 here as it breaks rendering of images in Frontend, at least when having "config.absRefPrefix = /" because every generated image (typo3temp/_processed/) is now referenced as
<img src="//typo3temp/_processed/whatever" with a double slash at the beginning whereas we had only 1 in beta6.
Same problem if an image is taken from typo3conf:
<img src="//typo3conf/ext/whatever/Resources/...", so it's not only related to processed images in FAL

#23 Updated by Xavier Perseguers almost 6 years ago

Problem is in method \TYPO3\CMS\Extbase\Service\ImageService::getImageUri() because $image->getPublicUrl() contains a leading / and the other one comes from config.absRefPrefix!

#24 Updated by Gerrit Code Review almost 6 years ago

  • Status changed from Needs Feedback to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28395

#25 Updated by Gerrit Code Review almost 6 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28395

#26 Updated by Gerrit Code Review almost 6 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28395

#27 Updated by Alexander Stehlik almost 6 years ago

Regression in #56927. Patch is on the way.

#28 Updated by Xavier Perseguers almost 6 years ago

  • Status changed from Under Review to Resolved

#29 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF