Bug #39290

Epic #65814: Make Indexed search extbase plugin shine

indexed_search pi2 (extbase/fluid plugin): Result titles are double-htmlspecialchared

Added by Andreas Kiessling about 7 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Must have
Category:
Indexed Search
Target version:
Start date:
2012-07-26
Due date:
% Done:

100%

TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

All links that are generated through Tx_IndexedSearch_Controller_SearchController->linkPage are passed through htmlspecialchars

return '<a href="' . htmlspecialchars($uri) . '"' . $target . '>' . htmlspecialchars($linkText) . '</a>';

But the $linkText is already prepared from the calling methods (because they e.g. generate some links on their own and so need to escape the title).
So the resulting HTML will be like this if there is an & in the page title:

News &amp;amp; Events

Tested on TYPO3 4.7.2

Associated revisions

Revision 73608b22 (diff)
Added by Gordon Brüggemann about 4 years ago

[BUGFIX] Fix double encoded link text

Resolves: #39290
Releases: master,6.2
Change-Id: If06c4e79e126fc347960a14da42cf3e6091d5c3e
Reviewed-on: http://review.typo3.org/41599
Reviewed-by: Dirk Koritnik <>
Reviewed-by: Ralf Merz <>
Reviewed-by: Marcus Schwemer <>
Tested-by: Marcus Schwemer <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>

Revision f2c8adac (diff)
Added by Gordon Brüggemann about 4 years ago

[BUGFIX] Fix double encoded link text

Resolves: #39290
Releases: master,6.2
Change-Id: If06c4e79e126fc347960a14da42cf3e6091d5c3e
Reviewed-on: http://review.typo3.org/41631
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>

History

#1 Updated by unkonsorten no-lastname-given over 6 years ago

Seems to be a general problem, also applies to marker based pi class. Verified for TYPO3 v 4.5-4.7
Occurs if plugin.tx_indexedsearch.search.detect_sys_domain_records is set. RealUrl doesn't work in this case, either even when creating links to pages on same domain.

#2 Updated by Mathias Schreiber over 4 years ago

  • Target version set to 7.5
  • Is Regression set to No

#3 Updated by Tymoteusz Motylewski over 4 years ago

  • Parent task set to #65814

#4 Updated by Benni Mack about 4 years ago

  • Target version changed from 7.5 to 7.4 (Backend)
  • Sprint Focus set to On Location Sprint

#5 Updated by Wouter Wolters about 4 years ago

  • Status changed from New to In Progress
  • Assignee set to Wouter Wolters

#6 Updated by Gerrit Code Review about 4 years ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/41599

#7 Updated by Gerrit Code Review about 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/41599

#8 Updated by Gordon Brüggemann about 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#9 Updated by Gerrit Code Review about 4 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/41631

#10 Updated by Gordon Brüggemann about 4 years ago

  • Status changed from Under Review to Resolved

#11 Updated by Anja Leichsenring over 3 years ago

  • Sprint Focus deleted (On Location Sprint)

#12 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF