Bug #40112

Show warning on translation by user without access to "l18n_parent"

Added by Stefan Neufeind about 9 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
DataHandler aka TCEmain
Target version:
Start date:
2012-08-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

Situation:
  • user with limited rights, non-admin
  • no access to "Page Content: Transl.Orig (l18n_parent)" configured
  • but access to multiple languages

User chooses to localise an element (through page-view or list-view).

Result:
  • Content gets copied but still ends up in the original language, since TYPO3 is not allowed to write the l18n_parent.

While the result is correct imho this should raise some kind of warning towards the user so he knows why something does not work out as planned and can get to his admin to fix the rights.


Related issues

Related to TYPO3 Core - Bug #89672: Missing l10n_parent field permission breaks page translation processClosed2019-11-13

Actions

Also available in: Atom PDF