Project

General

Profile

Actions

Bug #40850

closed

Form shows Fatal Error in Frontend

Added by Mario Rimann almost 12 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2012-09-12
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The changes from #40364 that were merged yesterday fixed the Form Wizard in the Backend. But the Frontend now throws the following Fatal Error:

Fatal error: Class '\TYPO3\CMS\Form\Filter\RemovexssFilter' not found in /path/to/typo3/sysext/core/Classes/Utility/GeneralUtility.php on line 4154

Related issues 3 (0 open3 closed)

Related to TYPO3 Core - Bug #40195: Namespace: Form: make FilterClosed2012-08-25

Actions
Related to TYPO3 Core - Bug #41215: Form fatals in frontend after class renamesClosedPhilipp Gampe2012-09-21

Actions
Has duplicate TYPO3 Core - Bug #42272: CheckboxgroupElement not foundClosed2012-10-22

Actions
Actions #1

Updated by Jigal van Hemert almost 12 years ago

  • Status changed from New to Needs Feedback

Can't reproduce it with current master. Can you post how to reproduce it? What is the form configuration you use?

Actions #2

Updated by Mario Rimann almost 12 years ago

Jigal van Hemert wrote:

Can't reproduce it with current master. Can you post how to reproduce it? What is the form configuration you use?

It's still the same configuration that we used when we reported #40825 (configuration is attached as .txt file to that bug report).

To reproduce, just open that page with the form CE in the Frontend and see the Fatal Error.

Actions #3

Updated by Jigal van Hemert almost 12 years ago

Tested your form from #40825 with current master on Windows and the form was displayed without any errors or flaws. Submitting an empty form showed the error messages for the three mandatory fields.

Seems OS X specific problem?

Actions #4

Updated by Dieter Bunkerd almost 12 years ago

Jigal van Hemert wrote:

Seems OS X specific problem?

No. The error appears also using Debian squeeze. I installed the Introduction Package (Beta2, after fixing #41084 with patch provided in #41245). Then navigating to examples/forms/ shows this error.

PHP 5.3.3-7+squeeze14 with Suhosin-Patch (cli) (built: Aug  6 2012 20:08:59) 
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    with Suhosin v0.9.32.1, Copyright (c) 2007-2010, by SektionEins GmbH
Actions #5

Updated by Ingo Pfennigstorf almost 12 years ago

Can confirm this error with clean caches on a SLES box with 6.0.0beta2

Actions #7

Updated by Christian Kuhn over 11 years ago

This is only reproducible on case sensitive filesystems ...

Actions #8

Updated by Gerrit Code Review over 11 years ago

  • Status changed from Needs Feedback to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16362

Actions #9

Updated by Gerrit Code Review over 11 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16362

Actions #10

Updated by Ingo Pfennigstorf over 11 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #11

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF