Project

General

Profile

Actions

Bug #44507

closed

Copied pages and folders have the same PID

Added by Andrea Herzog-Kienast about 11 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Pagetree
Start date:
2013-01-14
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
hard
Is Regression:
No
Sprint Focus:

Description

If you copy a pagetree or a part of a pagetree, the copied pages get - for some time - the same PIDs, as the original. If you then delete the copy you also delete the original.

If I copy a folder, and reload the pagetree, sometimes it´s copied 2 or tree times.

I tested this with TYPO3 4.5.22, 4.6.14 and some other guys I know, have the same problem.

Best,

Andrea


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #25056: Pagetree: No indication of pages being copied, when copying a branchClosed2011-02-16

Actions
Related to TYPO3 Core - Bug #51983: Lack of response on pagetree actions (copy,move,delete etc.) is confusingClosed2013-09-13

Actions
Actions #1

Updated by Oliver Hader about 11 years ago

  • Status changed from New to Needs Feedback

Can you please provide some more details on how those pages are copied, what the target page is, whether workspaces/localization is involved?
Maybe a step by step series of screenshot helps to at least test this behaviour. With the current bug description it's hard to reproduce... Thanks in adavance!

Actions #2

Updated by Daniel Wagner almost 11 years ago

I think to have a similar problem with TYPO3 CMS 4.5.25, no versioning and no workspaces.

If I use drag'n'drop in the pagetree with CTRL pressed to copy recursive a pagetree,
the copied page is gray and visible directly, but has the same PID as the original.
The subpage or only at least some them become visisble after pressing the pagetree
reload button. After reload the page has a new PID.

It happens that after some time (working as admin) an error message appears:
"Attempt to rawcopy/versionize record without copy permission".

Actions #3

Updated by Alexander Opitz over 10 years ago

  • Status changed from Needs Feedback to New
  • Target version deleted (4.5.23)
  • Is Regression set to No
Actions #4

Updated by Ernesto Baschny over 10 years ago

  • Status changed from New to Accepted
  • Assignee deleted (Andrea Herzog-Kienast)
  • Complexity set to hard

This is indeed an usability bug, as there is no feedback to the user that the "shadow copies" of the pages that were just copies are not really copied yet (but instead are being copied in the backend).

Jigal was trying to solve that in the extJS tree and noted that at least a CSS class was being set during copying ("fakeNode"), so there is hope that this could be solved. Just requires some ExtJS wizard to tackle it. Maybe Stefan Galinski has some spare time to take a look at it? :)

Actions #5

Updated by Mathias Schreiber about 9 years ago

  • Target version set to 7.4 (Backend)
Actions #6

Updated by Susanne Moog over 8 years ago

  • Target version changed from 7.4 (Backend) to 7.5
Actions #7

Updated by Benni Mack over 8 years ago

  • Target version changed from 7.5 to 8 LTS
Actions #8

Updated by filigivuji filigivuji over 7 years ago

This also affects TYPO3 6.2. This is particularly a problem if the editor is impatient (or perhaps the AJAX request times out) and wants to delete the copied page before the copy process is finished.

Actions #9

Updated by Benni Mack almost 7 years ago

  • Target version changed from 8 LTS to Candidate for patchlevel
Actions #10

Updated by Susanne Moog about 5 years ago

  • Status changed from Accepted to Needs Feedback

The pagetree got rewritten in the meantime - does the issue still exist in v9?

Actions #11

Updated by Riccardo De Contardi about 4 years ago

as far as I can see on version 9, when you copy a part of the pagetree (be sure to activate recursive copy in your user settings) , the whole pagertee section becomes "grayed" (overlayed with the spinning circle) so it seems it is not possible to interact with it until the copy has finished. I have not tested with a very large set of pages, so I don't know if the part about a message like "Attempt to rawcopy/versionize record without copy permission". can be still valid.

Actions #12

Updated by Riccardo De Contardi about 3 years ago

  • Status changed from Needs Feedback to Closed

I think it is safe to close this issue for now; it applies to versions that are no more maintained since long time;

If a similar issue comes out on newer TYPO3 versions, please open a new issue.

Thank you and best regards.

Actions

Also available in: Atom PDF