Task #54953

Epic #55070: Workpackages

Epic #54260: WP: FAL Missing Issues / Features / API

Story #54266: As an User I want FAL to be performant

FrontendContentAdapterService performs same actions several times

Added by Steffen Ritter over 5 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2014-01-13
Due date:
% Done:

50%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Sprint Focus:
Remote Sprint

Description

the FrontendContentAdapterService processes the same record again and again, for each ContentElement it is passed, too.
Create a local cache.


Related issues

Blocks TYPO3 Core - Bug #56209: Section Navigation: empty sectionIndex_uid Closed 2014-02-22

Associated revisions

Revision 3adf7835 (diff)
Added by Steffen Ritter over 5 years ago

[TASK] FrontendContentAdapterService processes record repeatedly

The FrontendContentAdapterService rewrites records so legacy
TypoScript is able to work on the files to. To do so it queries
the objects regarding the relations and fills the properties of
the record new line separated as known from pre-6.x records.

This change adds a runtime cache, so already processed records
of are not processed again, if the next cObject for the same
record is started.

Resolves: #54953
Releases: 6.2, 6.1
Change-Id: I1f632f175075c9d85079ea83e343e35867a1fcca
Reviewed-on: https://review.typo3.org/26786
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader
Reviewed-by: Benjamin Mack
Tested-by: Benjamin Mack

Revision fe7e00da (diff)
Added by Markus Klein over 5 years ago

Revert "[TASK] FrontendContentAdapterService processes record repeatedly"

This reverts commit 3adf78359015401648fcec4befe70e9bd0b7a2ea

This patch breaks section menus as it introduces invalid caching.
The original patch has not yet been backported.

Resolves: #56209
Resolves: #54953
Releases: 6.2
Change-Id: Ia3fc8718ed3907913a5538eee102260425f2cf16
Reviewed-on: https://review.typo3.org/27788
Reviewed-by: Markus Klein
Tested-by: Markus Klein

History

#1 Updated by Gerrit Code Review over 5 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/26786

#2 Updated by Gerrit Code Review over 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/26786

#3 Updated by Gerrit Code Review over 5 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/26786

#4 Updated by Steffen Ritter over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Steffen Ritter over 5 years ago

  • % Done changed from 100 to 90

#6 Updated by Markus Klein over 5 years ago

Causes regression. See #56209

#7 Updated by Gerrit Code Review over 5 years ago

  • Status changed from Resolved to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27788

#8 Updated by Gerrit Code Review over 5 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27788

#9 Updated by Gerrit Code Review over 5 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27788

#10 Updated by Gerrit Code Review over 5 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27805

#11 Updated by Markus Klein over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 90 to 100

#12 Updated by Ernesto Baschny over 5 years ago

  • Status changed from Resolved to Accepted
  • % Done changed from 100 to 50

This was reverted in https://review.typo3.org/#/c/27788/ due to regressions (#56209).

New review process started here: https://review.typo3.org/#/c/27805/.

Read Markus comments before working on it.

#13 Updated by Mathias Schreiber over 4 years ago

  • Assignee deleted (Steffen Ritter)
  • Sprint Focus set to On Location Sprint

#14 Updated by Anja Leichsenring about 4 years ago

  • Sprint Focus changed from On Location Sprint to Remote Sprint

#15 Updated by Mathias Schreiber almost 4 years ago

  • Target version deleted (6.2.0)

#16 Updated by Wouter Wolters over 3 years ago

  • Status changed from Accepted to Closed

Won't be fixed for 6.2 anymore.

Also available in: Atom PDF