Project

General

Profile

Actions

Feature #56726

closed

Trigger MetaDataExtraction after file upload

Added by Frans Saris over 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2014-03-10
Due date:
% Done:

100%

Estimated time:
PHP Version:
Tags:
Complexity:
easy
Sprint Focus:

Description

Currently the metadataExtraction is only called through scheduler task. So when a editor uploads a new file he has to wait until the scheduler task is triggered again.

For most file storage types it no problem to trigger the metadataExtraction direct after fileupload. Only in some special situations it isn't desirable to have to metadataExtraction direct after fileUpload/adding a file to the storage. To still support these use-cases a flag needs to be added to the storage so the integrator can disable the auto metadataExtraction for his special use-case.


Related issues 2 (0 open2 closed)

Has duplicate TYPO3 Core - Task #57546: Call ExtractionService on new files and not only Indexer::createIndexEntry()Closed2014-04-02

Actions
Is duplicate of TYPO3 Core - Bug #57408: Call of the meta extractor services for local storage possibleClosed2014-03-28

Actions
Actions

Also available in: Atom PDF