Bug #57706

Install tool marking symlinked directories as errors.

Added by Dave no-lastname-given about 8 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2014-04-07
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
no-brainer
Is Regression:
No
Sprint Focus:

Description

Hi

I am trying a 6.1.7 -> 6.2.0 upgrade and I noticed that the install tool is marking symlinked directories as errors that need to be corrected.

To me this is not an error as symlinks to directories are not errors that need to be corrected. I often symlink entire document roots to quickly switch served content.

I would suggest that if a symlink is detected that the symlink target is followed (using PHP readlink) and then verified. Of course a target can have a different name than it's link, so that would need to be taken in consideration. As long as the link has the correct naming there should be no problems.

Anything can be logically symlinked in a hosting environment for all manner of perfectly valid reasons. They should not be marked as errors unless they are truly broken links. (i.e. the target doesn't exist)

A symlink in itself is not an automatic error without further investigation.


Related issues

Related to TYPO3 Core - Bug #52993: index.php in DOC_ROOT must be symlinkedClosed2013-10-21

Actions
Related to TYPO3 Core - Task #80582: Enhance install tool core update actionClosedMona Muzaffar2017-03-30

Actions
Has duplicate TYPO3 Core - Bug #72382: Symlinking i.e. uploads folder not "allowed" according to Install Tool Closed2015-12-22

Actions
#1

Updated by Mathias Schreiber over 7 years ago

  • Target version changed from next-patchlevel to 7.4 (Backend)
#2

Updated by Susanne Moog almost 7 years ago

  • Category changed from Install Tool to 1601
#3

Updated by Gerrit Code Review almost 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/41383

#4

Updated by Gerrit Code Review almost 7 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/41383

#5

Updated by Georg Ringer almost 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#6

Updated by Gerrit Code Review almost 7 years ago

  • Status changed from Resolved to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/41404

#7

Updated by Christian Kuhn almost 7 years ago

  • Status changed from Under Review to Resolved
#8

Updated by Christian Kuhn almost 7 years ago

  • Status changed from Resolved to New
#9

Updated by Christian Kuhn almost 7 years ago

The first patches for this issue did not go far enough and had to be reverted:

There are several different scenarios the install tool should cope with. This should be allowed on configuration level:

  • example typo3_src: This is usually a link to a directory, but it may be a directory as well.
  • example index.php: This is usually a link to a file, but it may also be a file directly, too. The content of the file should have a defined content.
  • example fileadmin: This is usually a directory, but it may be a link pointing to a directory as well.

I propose to have a deeper look at the folderStructure DefaultFactory default structure definition and to align on a structural change of the configuration that allows these kind of configuration.

Hint: Since the folder structure can not be extended by extensions, we're relatively free to change this.

#10

Updated by Susanne Moog almost 7 years ago

  • Target version changed from 7.4 (Backend) to 7.5
#11

Updated by Benni Mack almost 7 years ago

  • Target version changed from 7.5 to 7 LTS
#12

Updated by Mathias Schreiber over 6 years ago

  • Target version deleted (7 LTS)
#13

Updated by Georg Ringer over 6 years ago

  • Status changed from New to Accepted
#14

Updated by Gerrit Code Review almost 6 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48999

#15

Updated by Gerrit Code Review almost 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48999

#16

Updated by Christian Kuhn about 5 years ago

  • Status changed from Under Review to Resolved
#17

Updated by Benni Mack over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF