Bug #58010

No backend login possible after Update 6.2.0 > 6.2.1

Added by Heinz Scheungrab about 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Backend User Interface
Target version:
Start date:
2014-04-17
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

I updated my TYPO3 Installation from 6.2.0 > 6.2.1
Now > Backend-login is not possible.


Files

Bildschirmfoto_2014-04-17_um_15.56.32.png (46.1 KB) Bildschirmfoto_2014-04-17_um_15.56.32.png Debug-1 Heinz Scheungrab, 2014-04-17 16:02
Bildschirmfoto_2014-04-17_um_16.00.53.png (51.1 KB) Bildschirmfoto_2014-04-17_um_16.00.53.png Debug-2 Heinz Scheungrab, 2014-04-17 16:02
patch_LoginFormHook.diff (629 Bytes) patch_LoginFormHook.diff workaround, disables concatenation and compression Dirk Klimpel, 2014-04-18 13:18

Related issues

Related to TYPO3 Core - Bug #57294: pageRenderer was resetted after render callClosed2014-03-25

Actions
Related to TYPO3 Core - Bug #58391: Suddenly Backend Logged 6.2.1Closed2014-05-01

Actions
Related to TYPO3 Core - Task #58581: Clarify reset in page renderer commentClosed2014-05-06

Actions
Related to TYPO3 Core - Bug #58582: Flag compressed files to exclude from compressionClosed2014-05-06

Actions
#1

Updated by Markus Klein about 7 years ago

What browser are you using, on which OS?
Can you check with the dev-tools of your browser if all requests sent to the server are working?

We have a similar issue here. FF and Chrome on Mac. The AJAX request for retrieving the RSA-key is canceled by the browser. We still have no clue why, since the same instance works fine for other users (all being on windows though).

#2

Updated by Heinz Scheungrab about 7 years ago

I'm using Safari 7.0.3 on Mac OS 10.9.2

I tested also:
Firefox, Chrome
Windows: IE 10, Firefox

How can i check it with dev-tools?

#3

Updated by Thomas Off about 7 years ago

In my opinion this is a general TYPO3 bug: when examining the JS files delivered to the browser and the ones in typo3temp/compressor, it looks as if TYPO3 does a compression on single files, then merges these files into one and compresses the result again. Therefore, the JS is not readable by the browser, RSA auth does not work and the login fails (the problem occurs as a combination of RSA security and JavaScript compression, if you disable RSA in the install tool, the login is working again).

#4

Updated by Andreas Krämer about 7 years ago

I had the same problem. Switching to development settings in the install tool solved it. It seems like the setting BE/debug = true is "fixing" the problem, but I don't know why ;)
Firebug says there is an illegal character in some merged js file if BE/debug = false? So I guess BE/debug = true doesn't compress the js files and therefore the mentioned problem by Thomas Off with multiple compression doesn't occur...

#6

Updated by Markus Klein about 7 years ago

  • Status changed from New to On Hold

I can confirm two problems: compression and version in filename.

So we have to create two tickets. Will do so tomorrow and will investigate on both.
Setting this to "on hold" meanwhile.

#7

Updated by Matthias Eberlein about 7 years ago

I can confirm this issue, but i have this also an 6.2.0-dev before. I use mostly openId for BElogin so i don't notice this. Login with openID works fine.
Regards
Matthias

#8

Updated by Dirk Klimpel about 7 years ago

The problem occurs with https://review.typo3.org/#/c/28893/

#10

Updated by Stefan Neufeind about 7 years ago

Could you please try if setting the [BE][compressionLevel] to 0 works? Since then no gzip should be performed.
You mean the files are first gzipped and then joined? That's of course obviously wrong then.

#11

Updated by Stefan Neufeind about 7 years ago

  • Is Regression changed from No to Yes
#12

Updated by Dirk Klimpel about 7 years ago

With [BE][compressionLevel] = 0 it works. One merged file without compression.

#13

Updated by Tanel Põld about 7 years ago

Yes, indeed, backend login works only with 'BE' 'compressionLevel' => '0'.

#14

Updated by Markus Klein about 7 years ago

See my comment from above, I already mentioned that:

I can confirm two problems: compression and version in filename.

And I will debug this and I will create two separate issues for that!

#15

Updated by Markus Klein about 7 years ago

  • Status changed from On Hold to Accepted
  • Assignee set to Markus Klein
  • Target version set to next-patchlevel

version number in filename seems to be correct. working on the compression now.

#16

Updated by Markus Klein about 7 years ago

Ok this is a regression to #57294.
The merged/compressed files are merged again.

Reverting this patch fixes the generation of the merged css/js files, but makes the BE login fail, since the patch is required for the new login to work.

#17

Updated by Gerrit Code Review about 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29579

#18

Updated by Helmut Hummel about 7 years ago

Markus Klein wrote:

Ok this is a regression to #57294.
The merged/compressed files are merged again.
Reverting this patch fixes the generation of the merged css/js files, but makes the BE login fail, since the patch is required for the new login to work.

I tend to revert #57294

The page renderer is not designed to work with a second rendering pass without resetting to its initial state.
This means: ->addFooter* calls are ignored when being called before first rendering pass and only work when done after first rendering pass.

Although this behavior is highly intransparent it cannot easily be fixed without heavy refactoring of the page renderer which most likely will break hooks.

The login can easily be fixed by using addJsFile instead of addJsFooterFile

#19

Updated by Gerrit Code Review about 7 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29581

#20

Updated by Gerrit Code Review about 7 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29582

#21

Updated by Helmut Hummel about 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#22

Updated by Gerrit Code Review about 7 years ago

  • Status changed from Resolved to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29582

#23

Updated by Wouter Wolters about 7 years ago

  • Status changed from Under Review to Resolved
#24

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF