Task #59112

Epic #58282: Workspaces Workpackage #2

Story #58284: Bug fixes & Behaviour

IRRE sorting not reflected

Added by Oliver Hader over 5 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Category:
Workspaces
Target version:
Start date:
2015-09-19
Due date:
% Done:

50%

TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
hard
Sprint Focus:

Description

Changing the IRRE element sorting might happen during editing the parent record or directly in the list view.
However, changed sorting is updated in the database but not visualized in the view. Besides that, move-placeholder are not filtered before handing over to the FormEngine.

Bildschirmfoto_2014-05-26_um_12.53.46.png View (30.6 KB) Oliver Hader, 2014-05-26 12:55

59112.patch View (759 Bytes) Andreas Kiessling, 2014-10-16 09:58

59112_v2.patch View (768 Bytes) Andreas Kiessling, 2014-10-16 14:35


Subtasks

Task #69967: Extract data overlay handling to common classClosed

Task #69966: Integrate localization and fallback resolving in PlainDataResolverNew


Related issues

Related to TYPO3 Core - Bug #62957: Sorting of files in file links canĀ“t be saved in draft workspace Closed 2014-11-14
Duplicated by TYPO3 Core - Bug #68663: WORKSPACES: IRRE field is lost sorting after saving Closed 2015-07-31

Associated revisions

Revision 6873c435 (diff)
Added by Oliver Hader about 4 years ago

[TASK] Add functional test cases for IRRE children without default sortby

In each, live and draft workspace:
  • create a tt_content element
  • with a nested 1:n hotel element
  • with a nested 1:n offer element
  • localize the created tt_conent element

The default sortby configuration of the hotel
table is disabled in $TCA.

Resolves: #59112
Releases: master, 6.2
Change-Id: I8e8eae3100046d21b7348cce7af6b592928b7c99
Reviewed-on: http://review.typo3.org/42839
Reviewed-by: Morton Jonuschat <>
Tested-by: Morton Jonuschat <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

Revision 361ad4de (diff)
Added by Oliver Hader about 4 years ago

[TASK] Add functional test cases for IRRE children without default sortby

In each, live and draft workspace:
  • create a tt_content element
  • with a nested 1:n hotel element
  • with a nested 1:n offer element
  • localize the created tt_content element

The default sortby configuration of the hotel
table is disabled in $TCA.

Change-Id: Iae313f0e64b8affc1134fcd8507171c73ced991c
Resolves: #59112
Releases: master, 6.2
Reviewed-on: http://review.typo3.org/43421
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

History

#1 Updated by Simon Apold over 5 years ago

I can confirm this issue.

To reproduce the problem follow these steps:
  • clean TYPO3 6.2.4 installation
  • install workspace-extension
  • create a new workspace
  • in the live workspace create a new page with an image content element and add several images to it
  • switch to the new created workspace and edit the image content element
  • change the order of the images ans save the content element

Neither in the backend nor in the frontend view the changed sorting will take effect. It will show the order of the live workspace.

#2 Updated by Andreas Kiessling about 5 years ago

I also confirm this issue, just tested it with a fresh git checkout.
Reordering inline elements worked in 4.x. Any idea, where to start debugging?

#3 Updated by Andreas Kiessling about 5 years ago

I think the problem comes from the change, that the relations now always point to the uid of the live record. I don't think, that the ordering can be determined through SQL, too much overlaying is applied to the records in PHP. The order is properly saved to the DB, but if you save the parent record again, the wrong order gets saved.

The attached patch seems to fix the issue for my 1:n relations and sys_file_references.

But you also need to do the same for all frontend logic! In 4.x, it was enough to determine the right uid to use for fetching the related records, e.g.
uid, _LOCALIZED_UID or _ORIG_uid (if you don't need any l10n overlays) Now you need to do the sorting afterwards

#4 Updated by Andreas Kiessling about 5 years ago

Is it safe to rely on $relatedRecords['count']? Sorting should only be done, if there is more then one record, see v2

#5 Updated by Mathias Schreiber over 4 years ago

  • Target version set to 7.5

#6 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39901

#7 Updated by Alexander Opitz over 4 years ago

  • Status changed from Under Review to New
  • Assignee set to Alexander Opitz

#8 Updated by Alexander Opitz over 4 years ago

  • Status changed from New to Under Review

#9 Updated by Alexander Opitz over 4 years ago

  • Target version changed from 7.5 to 6.2.14

#10 Updated by Alexander Opitz over 4 years ago

  • Target version changed from 6.2.14 to 6.2.15

#11 Updated by Gerrit Code Review about 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39901

#12 Updated by Gerrit Code Review about 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39901

#13 Updated by Gerrit Code Review about 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39901

#14 Updated by Gerrit Code Review about 4 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39901

#15 Updated by Alexander Opitz about 4 years ago

  • Target version changed from 6.2.15 to 6.2.16

#16 Updated by Gerrit Code Review about 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/42839

#17 Updated by Gerrit Code Review about 4 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43421

#18 Updated by Oliver Hader about 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#19 Updated by Oliver Hader about 4 years ago

  • Status changed from Resolved to Under Review

Setting to under review again, since only the function tests have been merged

#20 Updated by Oliver Hader about 4 years ago

  • Status changed from Under Review to Resolved

Follow-up in #69967

#21 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF