Project

General

Profile

Actions

Bug #61361

closed

Fluid template path fallback doesn't work in TypoScript object FLUIDTEMPLATE

Added by Christian Toffolo almost 10 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Fluid
Target version:
Start date:
2014-09-05
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

It looks like that the useful fallback feature of Fluid is implemented only in class TemplateView and not in class StandaloneView.

So a Typoscript like this doesn't work:

page {
  10 = FLUIDTEMPLATE
  10 {
  partialRootPath >
  partialRootPaths {
    10 = EXT:bootstrap_package/Resources/Private/Partials/Page/
    20 = EXT:my_extension/Resources/Private/Partials/Page/
  }
}

and produce a FE error:
Partial root path "typo3conf/ext/bootstrap_package/Resources/Private/Templates/Page/Partials" does not exist

IMHO, since this feature has been implemented in 6.2, it must be available also for TypoScript object FLUIDTEMPLATE and in TYPO3 6.2


Related issues 3 (0 open3 closed)

Related to TYPO3 Core - Bug #63066: FluidTemplateContentObject uses deprecated methodsClosedMarkus Klein2014-11-19

Actions
Related to TYPO3 Core - Bug #63367: superfluous ucfirst() kills FE rendering with FLUIDTEMPLATEClosedMarkus Klein2014-11-27

Actions
Precedes TYPO3 Core - Bug #63380: FLUIDTEMPLATE: New fallback paths miss stdWrapClosedAnja Leichsenring2014-11-27

Actions
Actions

Also available in: Atom PDF