Bug #65355

Story #69617: FormEngine bugs

Combination of Wizards looks a little bit ugly

Added by Stefan Froemken about 6 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Start date:
2015-02-26
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hello,

I know, such a configuration does not make sense, but it's only for testing:

'last_name' => array(
    'exclude' => 1,
    'label' => 'LLL:EXT:sftca/Resources/Private/Language/locallang_db.xlf:tx_sftca_domain_model_woman.last_name',
    'config' => array(
        'type' => 'input',
        'size' => 30,
        'eval' => 'trim',
        'wizards' => array(
            'select' => array(
                'type' => 'select',
                'mode' => 'append',
                'items' => array(
                    array('Yes', 1),
                    array('No', 0)
                )
            ),
            'colorpicker' => array(
                'type' => 'popup',
                'module' => array(
                    'name' => 'wizard_colorpicker',
                ),
                'dim' => '50x20',
                'tableStyle' => 'border:solid 1px black;',
                'exampleImg' => 'gfx/wizard_colorpickerex.jpg'
            ),
        ),
    ),
),

The "select" wizard wraps below the colorpicker instead of behind.
Further the colorpicker is not visible as "Color picker". It's more a checkbox. And it was opened in a new tab instead of a little popup as like DatePicker.
After selecting a color, the "checkbox" does not appear in selected color.

Stefan


Files

WrongPositionOfWizards.jpg (19.8 KB) WrongPositionOfWizards.jpg Wrong position of select-wizard Stefan Froemken, 2015-02-26 10:07
wizard icons.jpg (45.7 KB) wizard icons.jpg Jo Hasenau, 2016-10-30 14:34
#1

Updated by Wouter Wolters almost 6 years ago

  • Status changed from New to Needs Feedback

Stefan, please retry current master. Colorpicker got an update by me :)

#2

Updated by Stefan Froemken almost 6 years ago

Hello Wouter,

I have just checked out the latest master. Clear Cache. Update with composer.

For now, nothing has changed. Sorry.
Do you have tried my code example?

See you tomorrow

Stefan

#3

Updated by Susanne Moog almost 6 years ago

  • Target version changed from 7.4 (Backend) to 7.5
#4

Updated by Benni Mack over 5 years ago

  • Target version deleted (7.5)
#5

Updated by Alexander Opitz over 5 years ago

Hi,

does the problem still exists within newer versions of TYPO3 CMS (6.2.17 or 7.6.2)?

#6

Updated by Stefan Froemken over 5 years ago

The problem is still there.

After choosing a color from popup, the color field will be filled with the hex representation, but you don't "see" the choosen color.

What do you think about a dialog window instead of a popup?

#7

Updated by Alexander Opitz over 5 years ago

  • Status changed from Needs Feedback to New
  • Target version set to Candidate for patchlevel
#8

Updated by Frank Naegler about 5 years ago

  • Status changed from New to Needs Feedback

can you test it again with the new colorpicker on master?

#9

Updated by Christian Kuhn about 5 years ago

  • Parent task set to #69617
#10

Updated by Alexander Opitz over 4 years ago

ping

#11

Updated by Jo Hasenau over 4 years ago

The positioning of wizard icons in 7.6.11 still seems broken in different ways.

While buttons are not aligned correctly, additionally they are positioned too far away from the fields they belong to, especially on large screens.
This is due to display:table combined with width:100% which fully uses the available width even when the content of the table is much smaller.

#12

Updated by Christian Kuhn over 4 years ago

  • Status changed from Needs Feedback to Closed

on master, the wizard system was recently changed an now allows better positioning of stuff.

in 7.6, especially the mispositioned suggest wizard in group can be fixed by setting a _position=vertical for the wizards.

that should be ok for now, i'll close the issue.

Also available in: Atom PDF