Bug #66247

File Recycler doesn't collect deleted files anymore

Added by Florian Seirer over 4 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Must have
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2015-04-02
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
medium
Is Regression:
Yes
Sprint Focus:

Description

I'm talking about the folder named

_recycler_
, as referenced in this blogpost:
http://www.lacisoft.com/blog/2010/07/22/how-to-create-a-recycle-bin-trash-feature-in-typo3s-fileadmin/

In 6.2 there are no more deleted files moved to this folder, but it still has its own folder icon and scheduler task.
It was still working in TYPO3 4.7 (no FAL, of course), which I was just able to confirm in my local XAMPP installations.


Related issues

Duplicated by TYPO3 Core - Bug #66313: Fileadmin recycle folders not working Closed 2015-04-07

Associated revisions

Revision ac66cdb4 (diff)
Added by Michael Oehlhof almost 4 years ago

[BUGFIX] File Recycler collect deleted files again

Check if a recycler folder exists along the path from the storage root
to the file. If a matching folder is found move the file or folder to be
deleted to the closest recycler folder instead of immediately removing
them from the local filesystem.

Resolves: #66247
Resolves: #45327
Releases: master
Change-Id: Iac000095b86e7c888461aeb0347b9548d8edcd90
Reviewed-on: https://review.typo3.org/45076
Reviewed-by: Morton Jonuschat <>
Tested-by: Morton Jonuschat <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

History

#1 Updated by Felix Nagel over 4 years ago

I can confirm this for TYPO3 6.2.10.

#2 Updated by Wolfgang Wagner about 4 years ago

Still a problem in 6.2.14

#3 Updated by Ralf-Rene Schroeder almost 4 years ago

Still an anoying problem in 6.2.15...
Is there any solution/patch ???

#4 Updated by Philipp Gampe almost 4 years ago

  • Status changed from New to Accepted
  • Priority changed from Should have to Must have
  • Target version set to 7 LTS
  • Complexity set to medium

#5 Updated by Florian Seirer almost 4 years ago

This is still broken in TYPO3 7 LTS.

#6 Updated by Sacha Vorbeck almost 4 years ago

Confirmed for TYPO3 7.6

#7 Updated by Michael Oehlhof almost 4 years ago

  • Status changed from Accepted to In Progress
  • Assignee set to Michael Oehlhof

#8 Updated by Gerrit Code Review almost 4 years ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45076

#9 Updated by Gerrit Code Review almost 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45076

#10 Updated by Gerrit Code Review almost 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45076

#11 Updated by Gerrit Code Review almost 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45076

#12 Updated by Gerrit Code Review almost 4 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45076

#13 Updated by Michael Oehlhof almost 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#14 Updated by Clemens Riccabona over 3 years ago

Still not working in TYPO3 6.2.19

#15 Updated by Clemens Riccabona over 3 years ago

Is there any chance to get this into 6.2, which is a LTS officially supported till 3/2017, which is in fact a year from now!?

beside that, it is just ridiculous: in 6.2 we have got the cool new feature of cleaning recycler automagically via taskscheduler.
but guess what: recycler not been filled anyway.
really a funfact! ;)

#16 Updated by Florian Seirer over 3 years ago

You could just apply the patch to 6.2.19 yourself.
I did the same, and it worked.

But I agree, it should be in 6.2, since the feature has been there from the start. Can somebody reopen this?

#17 Updated by Clemens Riccabona over 3 years ago

Florian Seirer wrote:

You could just apply the patch to 6.2.19 yourself.
I did the same, and it worked.

Thanks for confirming, that the patch just works for 6.2 too!
Essentially I do not like (read: hate) to change the core myself everytime when there is a new version published ...
But better than the response: update to 7 LTS, the bug is gone there ... (also an advice I get sometimes when reporting bugs ...)

#18 Updated by Florian Seirer over 3 years ago

Now that it works again I found out that files can't be deleted if there is already another file with the same name in the recycler folder.

PHP Fatal error:  Class 'DateTimeImmutable' not found in /var/www/typo3/typo3-6.2.21/typo3/sysext/core/Classes/Resource/Driver/LocalDriver.php on line 827

Should i create a new issue for this?

#19 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF