Bug #66457

t3editor does not indent code with dot-syntax

Added by Ernst Went over 6 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
t3editor
Target version:
-
Start date:
2015-04-16
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Since 6.2 the following code in t3editor does not indent, since lib.logo contains a dot:

lib.logo = TEXT
lib.logo {
value = foo
}


Related issues

Related to TYPO3 Core - Bug #65809: Autocompletion fails in TypoScript-EditorClosed2015-03-18

Actions
Related to TYPO3 Core - Task #81885: Remove TypoScript syntax highlighting and code completionClosed2017-07-15

Actions
Has duplicate TYPO3 Core - Bug #68448: t3editor: I miss the spaces after {Closed2015-07-21

Actions
Has duplicate TYPO3 Core - Bug #81546: Indentation in t3editor is wrongClosed2017-06-12

Actions
#1

Updated by Malte Koitka over 6 years ago

Can confirm this for 6.2.12. It should be the same issue as #65809.

#2

Updated by Andreas Fernandez about 6 years ago

  • Target version set to 7 LTS

This seems to be a bug in the TypoScript lexer used by the editor. I didn't understand all of it's code yet, but I like to tackle it soon.

#3

Updated by Andreas Fernandez about 6 years ago

  • Status changed from New to Accepted
#4

Updated by Benni Mack almost 6 years ago

  • Target version changed from 7 LTS to 8 LTS

I consider updating the library here, which might solve a lot of other issues as well.

#5

Updated by Benni Mack about 4 years ago

  • Target version changed from 8 LTS to Candidate for patchlevel
#6

Updated by Bernd Wilke about 4 years ago

  • Related to Bug #81546: Indentation in t3editor is wrong added
#7

Updated by Bernd Wilke about 4 years ago

  • Related to deleted (Bug #81546: Indentation in t3editor is wrong)
#8

Updated by Bernd Wilke about 4 years ago

  • Has duplicate Bug #81546: Indentation in t3editor is wrong added
#9

Updated by Riccardo De Contardi about 4 years ago

  • Related to Task #81885: Remove TypoScript syntax highlighting and code completion added
#10

Updated by Riccardo De Contardi about 4 years ago

  • Status changed from Accepted to Closed
  • Target version deleted (Candidate for patchlevel)

Considering the issue #81885, I close this one for now.

Custom adoptions to codemirror is getting dropped in version 9 and no further changes will be done for TYPO3 CMS 7.x & TYPO3 CMS 8.x.

If this decision is wrong, please reopen or let me know and I will do.

Also available in: Atom PDF