Bug #65809

Autocompletion fails in TypoScript-Editor

Added by Philipp Müller over 6 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
t3editor
Target version:
-
Start date:
2015-03-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:
Stabilization Sprint

Description

Because of the bugfix #25594 the autocompletion of typoscript-code fails, when I try to create new Objects.

For example, when I create a new TEXT-Object like this:

lib.field_test = TEXT
lib.field_test {
  value = This is a test
}

The section after the first "lib." will be interpreted wrong:

Before the bugfix #25594 this worked correctly (see Screenshot 2) and when I remove the line 2603:

                    ch == "." ||

in typo3/sysext/t3editor/res/jslib/parse_typoscript/tokenizetyposcript.js, the problem is solved.


Files

Screenshot.png (16.6 KB) Screenshot.png Xavier Perseguers, 2015-04-13 11:38
screenshot1.png (8.4 KB) screenshot1.png Wrong Philipp Müller, 2015-04-22 11:43
screenshot2.png (8.31 KB) screenshot2.png Okay Philipp Müller, 2015-04-22 11:43

Related issues

Related to TYPO3 Core - Bug #25594: typed text does not get replaced correctly by code completion on right side of operatorClosedTobias Liebig2010-12-03

Actions
Related to TYPO3 Core - Bug #66457: t3editor does not indent code with dot-syntax Closed2015-04-16

Actions
Related to TYPO3 Core - Bug #68440: t3editor: stdWrap-properties missing in TEXT-cObjectClosedStefan Froemken2015-07-21

Actions
Related to TYPO3 Core - Task #81885: Remove TypoScript syntax highlighting and code completionClosed2017-07-15

Actions
#1

Updated by Suganja von Thaden over 6 years ago

Same bug! Anybody resolved this?

#2

Updated by Markus Klein over 6 years ago

  • Assignee set to Markus Klein
#3

Updated by Markus Klein over 6 years ago

  • Status changed from New to Accepted
  • Assignee changed from Markus Klein to Benni Mack
#4

Updated by Xavier Perseguers over 6 years ago

  • Target version changed from next-patchlevel to 6.2.12
  • Sprint Focus set to Stabilization Sprint
#5

Updated by Xavier Perseguers over 6 years ago

  • Description updated (diff)
#6

Updated by Xavier Perseguers over 6 years ago

#7

Updated by Xavier Perseguers over 6 years ago

  • File deleted (Screenshot 1.png)
#8

Updated by Xavier Perseguers over 6 years ago

  • File deleted (Screenshot 2.png)
#9

Updated by Xavier Perseguers over 6 years ago

  • Status changed from Accepted to Needs Feedback

Hi Philipp, I wrongly removed screenshots thinking there were same. As such I remember one did not have proper indentation but don't understand how to reproduce. Could you please either describe again the problem with screenshots (make sure NOT to include spaces within filename since one cannot embed them using !filename.png! syntax) or using just pre tags.

Is problem in 6.2 solely or in master as well?

#10

Updated by Xavier Perseguers over 6 years ago

  • Target version changed from 6.2.12 to next-patchlevel
  • Sprint Focus deleted (Stabilization Sprint)

not yet ready, postponed

#11

Updated by Philipp Müller over 6 years ago

Hi Xavier

Thank you for your response. The problem still exist in TYPO3 6.2.12.

You can reproduce it like this:
  1. Create new a file, for example "fileadmin/test.ts"
  2. Open it with t3editor*
  3. Write the test-code (do not copy&paste it from here)
// Test-Code
lib.field_test = TEXT
lib.field_test {
  value = This is a test
}

Wrong:
Wrong

Okay:
Okay

PS: *You must add ".ts" in textfile_ext in TYPO3_CONF_VARS to edit ts-files:

$TYPO3_CONF_VARS['SYS']['textfile_ext'] = 'ts,txt,html,htm,css,tmpl,js,sql,xml,csv,php,php3,php4,php5,php6,phpsh,inc,phtml';

#12

Updated by Bernd Wilke about 6 years ago

you can test it also with a simple typoscript-template record, editing the setup:

lib.mytest = COA
lib.mytest {
    // indention not recognized
    10 = TEXT
    10 {
        // indention recognized
       value = dummy
    }
    20 = TEXT
    20.value = dummy2
    20.stdWrap {
        // indention not recognized
        wrap = (|)
    }
}
marking all and pressing the tab key will result in all lines starting at the beginning (no indention) except the two lines inside 10

#13

Updated by Christian Kuhn about 6 years ago

  • Sprint Focus set to Stabilization Sprint
#14

Updated by Mathias Schreiber about 6 years ago

  • Target version changed from next-patchlevel to 6.2.13
#15

Updated by Markus Klein about 6 years ago

  • Status changed from Needs Feedback to Accepted
#16

Updated by Mathias Schreiber about 6 years ago

  • Sprint Focus deleted (Stabilization Sprint)
#17

Updated by Alexander Opitz about 6 years ago

  • Target version changed from 6.2.13 to 6.2.14
#18

Updated by Alexander Opitz about 6 years ago

  • Target version changed from 6.2.14 to 6.2.15
  • Sprint Focus set to Stabilization Sprint

As it is marked as regression and already was on stab board, I'll readd it there for 6.2.15

#19

Updated by Alexander Opitz almost 6 years ago

  • Target version changed from 6.2.15 to 6.2.16
#20

Updated by Benni Mack over 5 years ago

  • Assignee deleted (Benni Mack)
#21

Updated by Markus Klein over 5 years ago

  • Target version changed from 6.2.16 to Candidate for patchlevel

Please re-schedule for the next release once available.

#22

Updated by Riccardo De Contardi about 4 years ago

  • Related to Task #81885: Remove TypoScript syntax highlighting and code completion added
#23

Updated by Riccardo De Contardi about 4 years ago

  • Status changed from Accepted to Closed
  • Target version deleted (Candidate for patchlevel)

Considering the issue #81885, I close this one for now.

Custom adoptions to codemirror is getting dropped in version 9 and no further changes will be done for TYPO3 CMS 7.x & TYPO3 CMS 8.x.

If this decision is wrong, please reopen or let me know and I will do.

Also available in: Atom PDF