Project

General

Profile

Actions

Bug #72988

closed

losing Localization when moving elements (Typo 7.6.2)

Added by Samuel Weiss over 8 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
DataHandler aka TCEmain
Target version:
-
Start date:
2016-01-28
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

if you move localized content element in listview up or down it assume the Localization Key of the upper element.

Content 1 - EN
Content 2 - DE
Content 3 - DE

if you Content 3 up it will be localized as EN

Content 1 - EN
Content 3 - EN
Content 2 - DE

Running in
[sys_language_mode] = strict
[sys_language_overlay] = hideNonTranslated


Files

click_move.jpg (100 KB) click_move.jpg click on move "UP" König David, 2016-01-29 13:16
changed_lang.jpg (101 KB) changed_lang.jpg after reload König David, 2016-01-29 13:16

Related issues 4 (1 open3 closed)

Related to TYPO3 Core - Bug #70154: Extbase 'sorting' l10nmodeNew2015-09-28

Actions
Related to TYPO3 Core - Bug #39798: Language and colpos changes on re-ordering of Content ElementsClosed2012-08-14

Actions
Related to TYPO3 Core - Bug #59901: Move records in list module kills sys_language_uidClosed2014-06-26

Actions
Related to TYPO3 Core - Bug #25216: Repositioning of translated CE in the list module replaces language IDClosedJo Hasenau2011-03-01

Actions
Actions #1

Updated by Samuel Weiss over 8 years ago

  • Target version deleted (7.6.3)

Updated by König David over 8 years ago

I have the Same Problem in TYPO3 7LTS

Actions #3

Updated by König David over 8 years ago

The problem seems to be, that after moving an Object up or Down, the method \TYPO3\CMS\Core\DataHandling\DataHandler::fixCopyAfterDuplFields() is called, and the TCA configuration for the table tt_content is set to 'copyAfterDuplFields' => 'colPos,sys_language_uid'

Another problem is, that we can not change this value in AdditionalConfiguration.php, because the TCA of tt_content is loaded after that.

So at the moment you can only change this in a own Extension.

Greetings David

Actions #4

Updated by Samuel Weiss over 8 years ago

Yes that fix the problem in listview! Sadly it persists in pageview.
I cant move an all language element.

Actions #5

Updated by Mona Muzaffar about 7 years ago

  • Related to Bug #70154: Extbase 'sorting' l10nmode added
Actions #6

Updated by Riccardo De Contardi over 6 years ago

  • Category set to DataHandler aka TCEmain
Actions #7

Updated by Riccardo De Contardi over 6 years ago

  • Related to Bug #39798: Language and colpos changes on re-ordering of Content Elements added
Actions #8

Updated by Riccardo De Contardi over 6 years ago

  • Related to Bug #59901: Move records in list module kills sys_language_uid added
Actions #9

Updated by Riccardo De Contardi over 6 years ago

  • Related to Bug #25216: Repositioning of translated CE in the list module replaces language ID added
Actions #10

Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63646

Actions #11

Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63646

Actions #12

Updated by Gerrit Code Review over 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63646

Actions #13

Updated by Gerrit Code Review over 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63646

Actions #14

Updated by Gerrit Code Review over 4 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63646

Actions #15

Updated by Gerrit Code Review over 4 years ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64137

Actions #16

Updated by Christian Eßl over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #17

Updated by Benni Mack about 4 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF