Bug #75184

fileadmin/ (auto-created) is randomly offline

Added by Justus Moroni over 5 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2016-03-18
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
On Location Sprint

Description

I have the following problem in one TYPO3 installation:

The auto-created fileadmin goes randomly offline without an exception or any log entry.
This does not happen on a specific time or on a specific action.
The time is random and I can't find a action that triggers this effect.

The logging is configured to log every entry, even infos. There is no entry in the log.

I have a scheduler task that checks the fileadmin every minute and logs the time for me. After that it activates the fileadmin.
This is only a workaround and I would really need a solution.

I also checked the fileadmin permissions to see if there is a problem but this seems to be fine as well.

I also looked in the apache_log to see if any images could not be found but that was also clear.
I added temporary logging in the core functions to deactivate the file storage permanently and temporary. The problem is that these functions are not triggered at all.
The file is typo3/systext/core/Classes/Resource/ResourceStorage.php. The two functions are "markAsPermamentlyOffline" and "makrAsTemporaryOffline".

My Question:
Did anybody have the same strange bug?
Are there more things to check that I did not think of?
Are there any other parts where the fileadmin can be set offline?


Related issues

Related to TYPO3 Core - Bug #78256: All " are replaced with "/ when offline storage is present in the system and absRefPrefix is configuredClosed2016-10-12

Actions

Also available in: Atom PDF