Project

General

Profile

Actions

Bug #77956

closed

Exception in language menu when using addQueryString.exclude and cHashIncludePageId

Added by Thomas Ruta almost 8 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Caching
Target version:
Start date:
2016-09-15
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

Integration the last core Version 6.2.27
https://typo3.org/news/article/typo3-cms-6227-7611-and-831-released/

In different setups (With templavoila or grid & bootstrap) running 6.2. lts. After
deaktivation the 'cHashIncludePageId' all works again - otherwise the page becomes
inaccessable after cacheflush...

Core: Exception handler (WEB): Uncaught TYPO3 Exception: #1467983513: ID parameter
needs to be passed for the cHash calculation! As a temporary not recommended
workaround, you can set $GLOBALS['TYPO3_CONF_VARS']['FE']['cHashIncludePageId'] to
false to avoid this error. | RuntimeException thrown in file
/var/www/typo3_src/typo3_src-6.2.27/typo3/sysext/frontend/Classes/Page/CacheHashCalculator.php
in line 128.


Related issues 1 (0 open1 closed)

Has duplicate TYPO3 Core - Bug #78071: Language menu TypoScript configurations throws exception if cHashIncludePageId is setClosed2016-09-27

Actions
Actions #1

Updated by Gregor Sievert almost 8 years ago

This Bug comes from typo3/sysext/frontend/Classes/ContentObject/ContentObjectRenderer.php Line ~7192 in TYPO3 7.6.11 and in TYPO3 6.2.27 it is Line 6544

$exclude['id'] = 0;

Whenever some excludes are set, id will be excluded too. This wont work with

'cHashIncludePageId' => true,

Until this is fixed you can remove your excludes from eg. menus / news and so on.

In my Case it breaks while rendering a languagemenu with

'addQueryString.' => [
       'exclude' => 'L, cHash, q, tx_solr'
],

on the news detail page

Actions #2

Updated by Helmut Hummel almost 8 years ago

  • Status changed from New to Under Review

https://review.typo3.org/#/c/49943/

(don't know why this did not work automatically)

Actions #3

Updated by Stephan Großberndt almost 8 years ago

Did not work because the patch only sets a "Related" relation instead of "Resolves".

Actions #4

Updated by Gerrit Code Review almost 8 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49943

Actions #5

Updated by Gerrit Code Review almost 8 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49943

Actions #6

Updated by Gerrit Code Review almost 8 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49943

Actions #7

Updated by Stephan Großberndt over 7 years ago

  • Subject changed from you can set $GLOBALS['TYPO3_CONF_VARS']['FE']['cHashIncludePageId'] to false to avoid this error to Exception in language menu when using addQueryString.exclude and cHashIncludePageId
  • Tags deleted (#cacheflood)
Actions #8

Updated by Gerrit Code Review over 7 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49943

Actions #9

Updated by Jan Helke over 7 years ago

  • Sprint Focus set to On Location Sprint
Actions #10

Updated by Gerrit Code Review over 7 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49943

Actions #11

Updated by Stephan Großberndt over 7 years ago

  • Sprint Focus changed from On Location Sprint to Stabilization Sprint
Actions #12

Updated by Stephan Großberndt over 7 years ago

  • Target version set to 8.4
Actions #13

Updated by Sascha Nowak over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #14

Updated by Gerrit Code Review over 7 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50205

Actions #15

Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50206

Actions #16

Updated by Sascha Nowak over 7 years ago

  • Status changed from Under Review to Resolved
Actions #17

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF