Bug #81573

Scheduler config check and documentation

Added by Joe Jones about 4 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
CLI
Target version:
Start date:
2017-06-14
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
CLI cron documentation config check
Complexity:
Is Regression:
Sprint Focus:

Description

Dear core developers,

I am working with TYPO3 8.6.1 LTS now and had some problems to build the scheduler cron job. One probnlem is the documentation. The cron parameter changed and "scheduler" is depricated. It was not easy to find the correct parameter. But this works:

.../typo3/sysext/core/bin/typo3 scheduler:run

It would be nice to find this in the scheduler configuration check in the backenend. At the moment there is written erroneously:
Der Befehl, um den Planer von der Kommandozeile auszuf├╝hren lautet: "/.../typo3/sysext/core/bin/typo3 scheduler".

Also in the scheduler check there is a problem with the point "CLI-Skript". Even if the cron jobs works, the config checks alerts a missing cron job. In the point "Last run (Letzte Ausf├╝hrung) there is listet the correct timestamp for the last cron job run. TYPO3 seams to be conencted correcty, but the config check does not notice it.

Thanks
Martin


Files

scheduler-eng-ger.png (12.1 KB) scheduler-eng-ger.png Wittkiel Gruppe, 2017-06-15 12:42

Related issues

Related to TYPO3 Core - Task #79263: Migrate Scheduler CLI to Symfony CommandClosedBenni Mack2017-01-10

Actions
Related to TYPO3 Core - Bug #80868: Use new CLI binary in docs instead of cli_dispatch.phpshClosedBenni Mack2017-04-17

Actions
Related to Translation Team - Bug #82174: Missing translation on Core changesResolvedXavier Perseguers2017-08-22

Actions
Related to TYPO3 Core - Bug #85351: TYPO3 out of sync on translation serverClosedXavier Perseguers2018-06-22

Actions
Related to TYPO3 Core - Bug #83640: Scheduler: wrong command at config checkClosed2018-01-22

Actions
#1

Updated by Wittkiel Gruppe about 4 years ago

Same problem here. In german version "run" is missing. Last language-update today.

Operating system: Unix
TYPO3: 8.7.1
PHP: 7.0.18

#2

Updated by Joerg Kummer about 4 years ago

  • Related to Task #79263: Migrate Scheduler CLI to Symfony Command added
#3

Updated by Joerg Kummer about 4 years ago

  • Related to Bug #80868: Use new CLI binary in docs instead of cli_dispatch.phpsh added
#4

Updated by Joerg Kummer about 4 years ago

1. Issue is a missing translation on https://translation.typo3.org/de/TYPO3.core.scheduler/translate/Resources/Private/Language/locallang.xlf#unit=3147843
And this matches all languages/translation. Furthermore the translationserver did not get the change from the core change in april, which should be aktualized first.

#5

Updated by Joerg Kummer almost 4 years ago

  • Related to Bug #82174: Missing translation on Core changes added
#6

Updated by Joerg Kummer about 3 years ago

  • Related to Bug #85351: TYPO3 out of sync on translation server added
#7

Updated by Riccardo De Contardi almost 3 years ago

  • Related to Bug #83640: Scheduler: wrong command at config check added
#8

Updated by Christian Kuhn almost 3 years ago

  • Status changed from New to Closed

Hey. I'll close this issue for now since I guess it resolved meanwhile: the translation server should have got fresh code and the documentation got quite some love meanwhile. If the issue persists, please re-open it or create a new one and link this one.

Also available in: Atom PDF