Bug #85742

New page in workspace doesn't load content elements in preview

Added by Andreas Fernandez 12 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2018-08-03
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When I create a new page in a workspace and put some content elements on that page, I can't preview the page properly, because no content element is loaded in frontend. If the page itself gets published, previewing the page is possible again.

Tested with 8.7.17


Related issues

Related to TYPO3 Core - Bug #83065: Content is disappearing in Page module in workspaces Closed 2017-11-22
Related to TYPO3 Core - Bug #86845: Revert [BUGFIX] Set constraints in `FrontendRestrictionContainer` depending on workspace context Closed 2018-11-03
Related to TYPO3 Core - Bug #84985: Published workspace record show in page tree Closed 2018-05-12
Related to TYPO3 Core - Bug #85003: Workspace : no content show in preview frontend, if live page is hidden New 2018-05-14
Related to TYPO3 Core - Bug #82462: Workspace : no content show in preview, for a new page create in workspace, if this page is enable Under Review 2017-09-12

Associated revisions

Revision c3e7779c (diff)
Added by Andreas Fernandez 9 months ago

[BUGFIX] Set constraints in `FrontendRestrictionContainer` depending on workspace context

The `FrontendRestrictionContainer` must not respect the hidden flag, if
the request happens in a workspace context. The reason is that for
example pages that are created in a workspace have a hidden LIVE version,
which makes overlaying impossible.

This patch changes the behavior to act the same as
`PageRepository::enableFields()` does.

Resolves: #85742
Releases: master, 8.7
Change-Id: I5f1b12bcd8a63daf7eaa9bc9c065b96c343f6ab6
Reviewed-on: https://review.typo3.org/57822
Tested-by: TYPO3com <>
Reviewed-by: Sebastian Michaelsen <>
Tested-by: Sebastian Michaelsen <>
Reviewed-by: Frank Naegler <>
Tested-by: Frank Naegler <>

History

#1 Updated by Benni Mack 12 months ago

My colleagues had the same issue this morning

#2 Updated by Andreas Fernandez 12 months ago

New finding: a page that is created in the workspace has a "hidden" flag set in LIVE. If the page is also set to "hidden" in the workspace, previewing is possible again. Seems there is something wrong in TypoScriptFrontendController::determineIdIsHiddenPage().

#3 Updated by Gerrit Code Review 12 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57822

#4 Updated by Gerrit Code Review 12 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57822

#5 Updated by Gerrit Code Review 12 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57822

#6 Updated by Gerrit Code Review 12 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57822

#7 Updated by Gerrit Code Review 12 months ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57822

#8 Updated by Gerrit Code Review 12 months ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57822

#9 Updated by Gerrit Code Review 12 months ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57822

#10 Updated by Riccardo De Contardi 11 months ago

  • Related to Bug #83065: Content is disappearing in Page module in workspaces added

#11 Updated by Andreas Fernandez 10 months ago

  • Status changed from Under Review to Accepted

#12 Updated by Sebastian Michaelsen 9 months ago

  • Status changed from Accepted to Under Review

#13 Updated by Andreas Fernandez 9 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#14 Updated by Frank Naegler 9 months ago

  • Related to Bug #86845: Revert [BUGFIX] Set constraints in `FrontendRestrictionContainer` depending on workspace context added

#15 Updated by Frank Naegler 9 months ago

  • Status changed from Resolved to Accepted

The patch will be reverted, please refer to #86845 for more details.

#16 Updated by Oliver Hader 8 months ago

  • Related to Bug #84985: Published workspace record show in page tree added

#17 Updated by Riccardo De Contardi 8 months ago

  • Related to Bug #85003: Workspace : no content show in preview frontend, if live page is hidden added

#18 Updated by Riccardo De Contardi 4 months ago

  • Related to Bug #82462: Workspace : no content show in preview, for a new page create in workspace, if this page is enable added

#19 Updated by Riccardo De Contardi 4 months ago

  • Status changed from Accepted to Closed

I close this issue as a duplicate of #82462 please continue the discussion there. Thank you.
A reference to this issue has been created to keep track of it.

If you think that this is the wrong decision please reopen it or ping me.

Also available in: Atom PDF