Project

General

Profile

Actions

Bug #87743

closed

Pagetree filter: highlighting of search phrase

Added by Wolfgang Twaroch almost 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Pagetree
Target version:
-
Start date:
2019-02-19
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Feature:
  • when using the pagetree filter and entering a search phrase
  • all hits of this phrase should be highlighted in the pagetree

Has been in prior TYPO3 versions before v9.


Related issues 3 (1 open2 closed)

Related to TYPO3 Core - Bug #88259: Filtered pagetree should display child pagesClosed2019-05-03

Actions
Related to TYPO3 Core - Bug #91887: Page-Tree filter does not indicate its stateNew2020-07-29

Actions
Related to TYPO3 Core - Bug #93977: Broken acceptance test in page tree filterClosed2021-04-23

Actions
Actions #1

Updated by Josef Glatz almost 3 years ago

  • Tracker changed from Feature to Bug
  • Priority changed from Should have to Must have
  • TYPO3 Version set to 10
  • Is Regression set to Yes
Since this was available prior to v9 I've
  • changed the tracker to Bug
  • add flag Regressio
  • and set specific TYPO3 version

At time of writing this comment, v9 and v10/master are affected

Actions #2

Updated by Peter Kraume almost 3 years ago

I do a lot of editor trainings and editors coming from TYPO3 versions < 9 really miss the highlighting of the search phrase in the pagetree.
Another thing that is missing since v9: it's not possible to unfold the child pages of a page which is shown in filter mode.

Actions #3

Updated by Richard Haeser over 2 years ago

Peter Kraume wrote:

I do a lot of editor trainings and editors coming from TYPO3 versions < 9 really miss the highlighting of the search phrase in the pagetree.
Another thing that is missing since v9: it's not possible to unfold the child pages of a page which is shown in filter mode.

The unfold of child pages of a filtered page will be fixed with https://review.typo3.org/c/Packages/TYPO3.CMS/+/62086

Actions #4

Updated by Richard Haeser over 2 years ago

  • Related to Bug #88259: Filtered pagetree should display child pages added
Actions #5

Updated by Peter Kraume almost 2 years ago

I'd really love to see this missing feature fixed in v11 (or even better also v10).

Actions #6

Updated by Peter Kraume almost 2 years ago

  • Related to Bug #91887: Page-Tree filter does not indicate its state added
Actions #7

Updated by Gerrit Code Review almost 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68835

Actions #8

Updated by Gerrit Code Review almost 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68835

Actions #9

Updated by Gerrit Code Review almost 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68835

Actions #10

Updated by Gerrit Code Review almost 2 years ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68853

Actions #11

Updated by Benni Mack almost 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #12

Updated by Gerrit Code Review almost 2 years ago

  • Status changed from Resolved to Under Review

Patch set 2 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68853

Actions #13

Updated by Benjamin Franzke almost 2 years ago

  • Related to Bug #93977: Broken acceptance test in page tree filter added
Actions #14

Updated by Gerrit Code Review almost 2 years ago

Patch set 3 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68853

Actions #15

Updated by Gerrit Code Review almost 2 years ago

Patch set 4 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68853

Actions #16

Updated by Benni Mack almost 2 years ago

  • Status changed from Under Review to Resolved
Actions #17

Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF