Bug #87960

No way to disable deprecation message logged to file

Added by R3 H6 over 1 year ago. Updated 7 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Logging
Target version:
-
Start date:
2019-03-20
Due date:
% Done:

0%

TYPO3 Version:
10
PHP Version:
Tags:
CodingNight
Complexity:
Is Regression:
Sprint Focus:

Description

Any call to GeneralUtility::deprecationLog creates one line:

20-03-2019 05:26: GeneralUtility::deprecationLog() will be removed in TYPO3 v10.0, use "trigger_error("Given reason", E_USER_DEPRECATED);" to log deprecations.

This line is written even when following option is set:

$GLOBALS['TYPO3_CONF_VARS']['LOG']['TYPO3']['CMS']['deprecations']['writerConfiguration'][\TYPO3\CMS\Core\Log\LogLevel::NOTICE] = [];

Usually some plugin like news, vhs, etc call GeneralUtility::deprecationLog()


Related issues

Related to TYPO3 Core - Task #82438: Use native trigger_error and ErrorHandler for deprecations Closed 2017-09-10
Related to TYPO3 Core - Bug #90250: Make it possible to entirely turn off deprecation logging via configuration in TYPO3 9.x Closed 2020-01-29

History

#1 Updated by Markus Klein over 1 year ago

  • Related to Task #82438: Use native trigger_error and ErrorHandler for deprecations added

#2 Updated by Rene Tobias Tobias over 1 year ago

Hey, i have the same problem :(

#3 Updated by Riccardo De Contardi about 1 year ago

  • Tags set to CodingNight

#4 Updated by Sybille Peters 9 months ago

Can you check if #90250 is a duplicate? Sorry, did not see this issue when I searched for it.

#5 Updated by Sybille Peters 9 months ago

  • Related to Bug #90250: Make it possible to entirely turn off deprecation logging via configuration in TYPO3 9.x added

#6 Updated by Benni Mack 7 months ago

  • Status changed from New to Closed

I'm closing this is as a duplicate to #80250 where an issue exists.

#7 Updated by Katharina Strasser 7 months ago

  • TYPO3 Version changed from 9 to 10

With the current build of typo3 v10.3 its also not possible to disable the deprecations log.

Just with a few calls of the site causes very large logfiles.

#8 Updated by Sybille Peters 7 months ago

This issue was closed as duplicate. You should continue in #90250

#9 Updated by Sybille Peters 7 months ago

@ Katharina Strasser About deprecations in 10. I am not aware of a problem there currently. The functions that were used to write in var/log/deprecation_<hash>.log have been removed in 10.

Deprecation logging via the logging framework can be disabled (and should not be logged in the production context because they are level NOTICE), see https://docs.typo3.org/m/typo3/reference-coreapi/master/en-us/ApiOverview/Deprecation/Index.html#disabling-deprecation-errors

If you have problems, please add additional information in #90250

Also available in: Atom PDF