Project

General

Profile

Actions

Bug #91507

closed

System information very slow

Added by Raphael Zschorsch almost 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2020-05-27
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I have a strange problem not limited to any versions. I started to notice it with newer versions like 9.5.16 and up but the error occurs in older projects with i.e. 9.5.13.

The initial backend login and every browser reload of the backend takes up to 10-20 seconds. I didn't notice this with the older project 9.5.13 before, but now it's in every project with TYPO3 9, every browser and on different hosting environments.

/typo3/index.php?route=%2Fajax%2Fsystem-information%2Frender&token=xyz&skipSessionUpdate=1 is taking way too long to load each time.

I'm experiencing the same thing with TYPO3 10.


Files

image.png (51.2 KB) image.png Stack Trace Markus Klein, 2020-06-17 15:40

Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Task #90934: Make automatic background version checks an opt-in featureClosed2020-04-02

Actions
Related to TYPO3 Core - Feature #84549: Use new REST api for get.typo3.org and integrate update checkClosedSusanne Moog2018-03-28

Actions
Actions #1

Updated by Raphael Zschorsch almost 4 years ago

This happens in a freshly installed TYPO3 instance with no configuration and extensions whatsoever.

I commented out this line in

/sysext/backend/ext_localconf.php
to deactivate the system information toolbar item completely and then, the backend is again blazingly fast upon reload.

// $GLOBALS['TYPO3_CONF_VARS']['BE']['toolbarItems'][1435433110] = \TYPO3\CMS\Backend\Backend\ToolbarItems\SystemInformationToolbarItem::class;
Actions #2

Updated by Andreas Kienast almost 4 years ago

  • Status changed from New to Accepted

I'm very confident this is related to https://review.typo3.org/c/Packages/TYPO3.CMS/+/56468/ which contacts get.typo3.org to check whether an update is available. Due to the limitations of the toolbar API, this request is executed during initial rendering.

A possible fix for the toolbar API is to introduce a DeferredToolbarItemInterface, which allows to skip the rendering of a toolbar item's dropdown. This is non-breaking but would introduce a new interface that qualifies as a feature, thus it is v11 only.

Actions #3

Updated by Simon Gilli almost 4 years ago

I have also created a ticket for get.typo3.org which seems to me the reason for the delays see https://github.com/TYPO3/get.typo3.org/issues/169. Will try to find a solution here a.s.a.p.

Actions #4

Updated by Markus Klein almost 4 years ago

Actions #5

Updated by Gerrit Code Review almost 4 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64904

Actions #6

Updated by Gerrit Code Review almost 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64904

Actions #7

Updated by Gerrit Code Review almost 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64904

Actions #8

Updated by Gerrit Code Review almost 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64904

Actions #9

Updated by Gerrit Code Review almost 4 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64904

Actions #10

Updated by Gerrit Code Review almost 4 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64904

Actions #11

Updated by Markus Klein almost 4 years ago

  • Related to Task #90934: Make automatic background version checks an opt-in feature added
Actions #12

Updated by Gerrit Code Review over 3 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64904

Actions #13

Updated by Gerrit Code Review over 3 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64904

Actions #14

Updated by Christian Kuhn over 3 years ago

  • Related to Feature #84549: Use new REST api for get.typo3.org and integrate update check added
Actions #15

Updated by Gerrit Code Review over 3 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64904

Actions #16

Updated by Gerrit Code Review over 3 years ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65160

Actions #17

Updated by Markus Klein over 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #18

Updated by Gerrit Code Review over 3 years ago

  • Status changed from Resolved to Under Review

Patch set 2 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65160

Actions #19

Updated by Gerrit Code Review over 3 years ago

Patch set 3 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65160

Actions #20

Updated by Gerrit Code Review over 3 years ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65183

Actions #21

Updated by Markus Klein over 3 years ago

  • Status changed from Under Review to Resolved
Actions #22

Updated by Benni Mack over 3 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF