Project

General

Profile

Actions

Bug #92036

closed

Story #92091: PageTree related flaws TYPO3 v9.5.20/21-dev or v10.4.6/7-dev

New behaviour of page tree filter might more easily submit "monster queries" or too many queries

Added by Sybille Peters over 3 years ago. Updated 9 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Pagetree
Target version:
-
Start date:
2020-08-17
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

The behaviour of the filter was changed in https://review.typo3.org/c/Packages/TYPO3.CMS/+/65208 to submit a query automatically after a small delay so that the query is submitted when you stop typing.

However, if you do not type fast enough, several (unnecessary) queries will be submitted.

Example

You want to filter for "abc". Since you are a slow typer, 3 queries are submitted for pages matching:

  • "a"
  • "ab"
  • "abc"

You only need the third one. Also, the result sets of the queries which are unnecessarily being submitted might be quite large for
sites with a large number of pages.

Suggestion

  • Have a minimum number of characters before the query is submitted automatically (e.g. 2 or 3)
  • force submit by pressing ENTER

For me, the pressing of ENTER which was introduced with previous patch was not a problem. In fact, I found it preferrable to current behaviour because it reduces amount of unnecessary queries and you had direct control over what was fetched.


Related issues 3 (1 open2 closed)

Related to TYPO3 Core - Bug #91878: Fatal error in pagetree 9.5.20Closed2020-07-28

Actions
Related to TYPO3 Core - Bug #92033: "Page tree error: Got unexpected reponse" with filter - allowed memory size exhaustedClosed2020-08-17

Actions
Related to TYPO3 Core - Epic #93547: Collection of problems with large sitesAccepted2021-02-19

Actions
Actions

Also available in: Atom PDF